about summary refs log tree commit diff
path: root/pkgs/top-level
diff options
context:
space:
mode:
authorAnderson Torres <torres.anderson.85@protonmail.com>2024-03-07 21:56:58 -0300
committerAnderson Torres <torres.anderson.85@protonmail.com>2024-03-08 15:59:12 -0300
commit9f3840785bed83234dd27b293ad30b38e4aece29 (patch)
tree291449d1a65f833696cd0b199a14eaeddb736ea2 /pkgs/top-level
parent4387bbfaaac6349ff8ee884aa86624909243c514 (diff)
downloadnixlib-9f3840785bed83234dd27b293ad30b38e4aece29.tar
nixlib-9f3840785bed83234dd27b293ad30b38e4aece29.tar.gz
nixlib-9f3840785bed83234dd27b293ad30b38e4aece29.tar.bz2
nixlib-9f3840785bed83234dd27b293ad30b38e4aece29.tar.lz
nixlib-9f3840785bed83234dd27b293ad30b38e4aece29.tar.xz
nixlib-9f3840785bed83234dd27b293ad30b38e4aece29.tar.zst
nixlib-9f3840785bed83234dd27b293ad30b38e4aece29.zip
pyp: refactor
- Merge and refactor the two packages
  - pyp and python3Packages.pyp should be the same file!
- set bc and jq appropriately
- get rid of rec
- get rid of nested with
- set pyproject
- set meta.mainProgram
Diffstat (limited to 'pkgs/top-level')
-rw-r--r--pkgs/top-level/all-packages.nix3
-rw-r--r--pkgs/top-level/python-packages.nix2
2 files changed, 4 insertions, 1 deletions
diff --git a/pkgs/top-level/all-packages.nix b/pkgs/top-level/all-packages.nix
index bed825679f8c..839bb25e44e6 100644
--- a/pkgs/top-level/all-packages.nix
+++ b/pkgs/top-level/all-packages.nix
@@ -12341,6 +12341,9 @@ with pkgs;
 
   pywal = with python3Packages; toPythonApplication pywal;
 
+  # pyp: tests fail on Python 3.11 -- why?
+  pyp = with python310Packages; toPythonApplication pyp;
+
   pystring = callPackage ../development/libraries/pystring { };
 
   raysession = python3Packages.callPackage ../applications/audio/raysession {};
diff --git a/pkgs/top-level/python-packages.nix b/pkgs/top-level/python-packages.nix
index 377d5e2587d1..b57def8367b5 100644
--- a/pkgs/top-level/python-packages.nix
+++ b/pkgs/top-level/python-packages.nix
@@ -11160,7 +11160,7 @@ self: super: with self; {
   pyomo = callPackage ../development/python-modules/pyomo { };
 
   pyp = callPackage ../development/python-modules/pyp {
-    inherit (pkgs) jq;
+    inherit (pkgs) bc jq;
   };
 
   pypng = callPackage ../development/python-modules/pypng { };