about summary refs log tree commit diff
path: root/pkgs/top-level
diff options
context:
space:
mode:
authorFrancois-Rene Rideau <fare@tunes.org>2020-03-21 00:52:59 -0400
committerFrancois-Rene Rideau <fare@tunes.org>2020-05-17 15:48:12 -0400
commit9456522528a118d9eeb078a77064a4f85ae9b887 (patch)
tree476061b28ef59a7feb81becb7c6e81572d626446 /pkgs/top-level
parent28c2c0156da98dbe553490f904da92ed436df134 (diff)
downloadnixlib-9456522528a118d9eeb078a77064a4f85ae9b887.tar
nixlib-9456522528a118d9eeb078a77064a4f85ae9b887.tar.gz
nixlib-9456522528a118d9eeb078a77064a4f85ae9b887.tar.bz2
nixlib-9456522528a118d9eeb078a77064a4f85ae9b887.tar.lz
nixlib-9456522528a118d9eeb078a77064a4f85ae9b887.tar.xz
nixlib-9456522528a118d9eeb078a77064a4f85ae9b887.tar.zst
nixlib-9456522528a118d9eeb078a77064a4f85ae9b887.zip
Refactor Gambit support
Refactor the build rule:
- Put files in $out/gambit instead of $out.
- Make the optimization setting easy to override.
- Make use of gccStdenv more explicit at this level.
- Support new-style runtime options for forcing UTF-8 I/O.
- Override the PACKAGE_VERSION and PACKAGE_STRING with git version.
- Note that the license is lgpl21, not lpgl2 (Note: also dual asl20).
- Try and fail to meaningfully add missing runtimeDeps.
- Build using NIX_BUILD_CORES.
Diffstat (limited to 'pkgs/top-level')
-rw-r--r--pkgs/top-level/all-packages.nix3
1 files changed, 2 insertions, 1 deletions
diff --git a/pkgs/top-level/all-packages.nix b/pkgs/top-level/all-packages.nix
index 729f97d65a1e..8a26aea2beb2 100644
--- a/pkgs/top-level/all-packages.nix
+++ b/pkgs/top-level/all-packages.nix
@@ -8203,7 +8203,8 @@ in
   fpc = callPackage ../development/compilers/fpc { };
 
   gambit = callPackage ../development/compilers/gambit { stdenv = gccStdenv; };
-  gambit-unstable = callPackage ../development/compilers/gambit/unstable.nix { stdenv = gccStdenv; };
+  gambit-unstable = callPackage ../development/compilers/gambit/unstable.nix { };
+  gambit-support = callPackage ../development/compilers/gambit/gambit-support.nix { };
   gerbil = callPackage ../development/compilers/gerbil { stdenv = gccStdenv; };
   gerbil-unstable = callPackage ../development/compilers/gerbil/unstable.nix { stdenv = gccStdenv; };