about summary refs log tree commit diff
path: root/pkgs/top-level
diff options
context:
space:
mode:
authorMichael Raskin <7c6f434c@mail.ru>2016-08-01 17:22:28 +0200
committerMichael Raskin <7c6f434c@mail.ru>2016-08-01 17:22:41 +0200
commit8fd84fcb870b3d55f6760ede5bb46aa57bbec64e (patch)
tree5ebe0d3ef83a2a501f14e86afd9255b131546edd /pkgs/top-level
parent909249dbe233522e6a2e6f3c056a49f8efb7ad46 (diff)
downloadnixlib-8fd84fcb870b3d55f6760ede5bb46aa57bbec64e.tar
nixlib-8fd84fcb870b3d55f6760ede5bb46aa57bbec64e.tar.gz
nixlib-8fd84fcb870b3d55f6760ede5bb46aa57bbec64e.tar.bz2
nixlib-8fd84fcb870b3d55f6760ede5bb46aa57bbec64e.tar.lz
nixlib-8fd84fcb870b3d55f6760ede5bb46aa57bbec64e.tar.xz
nixlib-8fd84fcb870b3d55f6760ede5bb46aa57bbec64e.tar.zst
nixlib-8fd84fcb870b3d55f6760ede5bb46aa57bbec64e.zip
libreoffice: reinstante and use curl 7.48 before the removal of a required feature. CVE's not fixed because of that decision: a Windows-specific DLL substitution and a mbedSSL/PolarSSL specific insufficient certificate validation
Diffstat (limited to 'pkgs/top-level')
-rw-r--r--pkgs/top-level/all-packages.nix9
1 files changed, 9 insertions, 0 deletions
diff --git a/pkgs/top-level/all-packages.nix b/pkgs/top-level/all-packages.nix
index c35136b1637c..79ae2523ff69 100644
--- a/pkgs/top-level/all-packages.nix
+++ b/pkgs/top-level/all-packages.nix
@@ -1235,6 +1235,14 @@ in
     scpSupport = zlibSupport && !stdenv.isSunOS && !stdenv.isCygwin;
   };
 
+  curl_7_48 = callPackage ../tools/networking/curl/7.48.nix rec {
+    fetchurl = fetchurlBoot;
+    http2Support = !stdenv.isDarwin;
+    zlibSupport = true;
+    sslSupport = zlibSupport;
+    scpSupport = zlibSupport && !stdenv.isSunOS && !stdenv.isCygwin;
+  };
+
   curl3 = callPackage ../tools/networking/curl/7.15.nix rec {
     zlibSupport = true;
     sslSupport = zlibSupport;
@@ -13720,6 +13728,7 @@ in
     harfbuzz = harfbuzz.override {
       withIcu = true; withGraphite2 = true;
     };
+    curl = curl_7_48;
   });