about summary refs log tree commit diff
path: root/pkgs/top-level
diff options
context:
space:
mode:
authorAlyssa Ross <hi@alyssa.is>2020-01-09 21:35:56 +0000
committerAlyssa Ross <hi@alyssa.is>2020-01-30 23:14:45 +0000
commit881dd9963ffe81396ffdc9748182a1423ac86018 (patch)
tree32b60e0b0d9673aa4e366778c6dbb9b8ea480a27 /pkgs/top-level
parenta8538a73a782779ce6e4191c779de470f938d5fd (diff)
downloadnixlib-881dd9963ffe81396ffdc9748182a1423ac86018.tar
nixlib-881dd9963ffe81396ffdc9748182a1423ac86018.tar.gz
nixlib-881dd9963ffe81396ffdc9748182a1423ac86018.tar.bz2
nixlib-881dd9963ffe81396ffdc9748182a1423ac86018.tar.lz
nixlib-881dd9963ffe81396ffdc9748182a1423ac86018.tar.xz
nixlib-881dd9963ffe81396ffdc9748182a1423ac86018.tar.zst
nixlib-881dd9963ffe81396ffdc9748182a1423ac86018.zip
mailman-web: use upstream, improve NixOS module
Previously, some files were copied into the Nixpkgs tree, which meant
we wouldn't easily be able to update them, and was also just messy.

The reason it was done that way before was so that a few NixOS
options could be substituted in.  Some problems with doing it this way
were that the _package_ changed depending on the values of the
settings, which is pretty strange, and also that it only allowed those
few settings to be set.

In the new model, mailman-web is a usable package without needing to
override, and I've implemented the NixOS options in a much more
flexible way.  NixOS' mailman-web config file first reads the
mailman-web settings to use as defaults, but then it loads another
configuration file generated from the new services.mailman.webSettings
option, so _any_ mailman-web Django setting can be customised by the
user, rather than just the three that were supported before.  I've
kept the old options, but there might not really be any good reason to
keep them.
Diffstat (limited to 'pkgs/top-level')
-rw-r--r--pkgs/top-level/all-packages.nix2
1 files changed, 2 insertions, 0 deletions
diff --git a/pkgs/top-level/all-packages.nix b/pkgs/top-level/all-packages.nix
index 255b5dfd90bc..92d90410ee1e 100644
--- a/pkgs/top-level/all-packages.nix
+++ b/pkgs/top-level/all-packages.nix
@@ -15325,6 +15325,8 @@ in
 
   mailman-rss = callPackage ../development/python-modules/mailman-rss { };
 
+  mailman-web = with python3.pkgs; toPythonApplication mailman-web;
+
   mattermost = callPackage ../servers/mattermost { };
   matterircd = callPackage ../servers/mattermost/matterircd.nix { };
   matterbridge = callPackage ../servers/matterbridge { };