about summary refs log tree commit diff
path: root/pkgs/top-level
diff options
context:
space:
mode:
authorSebastien Maret <sebastien.maret@univ-grenoble-alpes.fr>2018-11-03 13:40:48 +0100
committerFrederik Rietdijk <fridh@fridh.nl>2018-11-11 10:14:25 +0100
commit880fae6a084a66dae6d92dd5fe4416bd4eed4978 (patch)
treee53f541d152b334f4cb87d93a31adf667ac2d614 /pkgs/top-level
parent961180afc8ef4efd94487e2fc9d86b10a6099d93 (diff)
downloadnixlib-880fae6a084a66dae6d92dd5fe4416bd4eed4978.tar
nixlib-880fae6a084a66dae6d92dd5fe4416bd4eed4978.tar.gz
nixlib-880fae6a084a66dae6d92dd5fe4416bd4eed4978.tar.bz2
nixlib-880fae6a084a66dae6d92dd5fe4416bd4eed4978.tar.lz
nixlib-880fae6a084a66dae6d92dd5fe4416bd4eed4978.tar.xz
nixlib-880fae6a084a66dae6d92dd5fe4416bd4eed4978.tar.zst
nixlib-880fae6a084a66dae6d92dd5fe4416bd4eed4978.zip
matplotlib: 2.2.3 -> 3.0.2
Python 3 will use the new matplotlib 3.x while Python 2
will use 2.x.

matplotlib: keep 2.2.3 for Python2k
Diffstat (limited to 'pkgs/top-level')
-rw-r--r--pkgs/top-level/python-packages.nix6
1 files changed, 4 insertions, 2 deletions
diff --git a/pkgs/top-level/python-packages.nix b/pkgs/top-level/python-packages.nix
index f817cb3d0617..e4e561682bf0 100644
--- a/pkgs/top-level/python-packages.nix
+++ b/pkgs/top-level/python-packages.nix
@@ -2746,9 +2746,11 @@ in {
 
   mathics = callPackage ../development/python-modules/mathics { };
 
-  matplotlib = callPackage ../development/python-modules/matplotlib {
+  matplotlib = let
+    path = if isPy3k then ../development/python-modules/matplotlib/default.nix else
+      ../development/python-modules/matplotlib/2.nix;
+  in callPackage path {
     stdenv = if stdenv.isDarwin then pkgs.clangStdenv else pkgs.stdenv;
-    enableGhostscript = true;
     inherit (pkgs.darwin.apple_sdk.frameworks) Cocoa;
   };