about summary refs log tree commit diff
path: root/pkgs/top-level
diff options
context:
space:
mode:
authorJörg Thalheim <Mic92@users.noreply.github.com>2018-12-01 00:43:02 +0000
committerGitHub <noreply@github.com>2018-12-01 00:43:02 +0000
commit84162175a3ff1b9649b65b5201c063a51cd40368 (patch)
tree42ebad1a88d0b1bfe8fab54f815841a1e12ea342 /pkgs/top-level
parent3a3513e7e7d4c252d6240a62d377ef723509d8c0 (diff)
parent694b4d29e1d0e4c86d497da437a3eed90910a7db (diff)
downloadnixlib-84162175a3ff1b9649b65b5201c063a51cd40368.tar
nixlib-84162175a3ff1b9649b65b5201c063a51cd40368.tar.gz
nixlib-84162175a3ff1b9649b65b5201c063a51cd40368.tar.bz2
nixlib-84162175a3ff1b9649b65b5201c063a51cd40368.tar.lz
nixlib-84162175a3ff1b9649b65b5201c063a51cd40368.tar.xz
nixlib-84162175a3ff1b9649b65b5201c063a51cd40368.tar.zst
nixlib-84162175a3ff1b9649b65b5201c063a51cd40368.zip
Merge pull request #51180 from mayflower/xorg-cross
treewide: cross-fixes
Diffstat (limited to 'pkgs/top-level')
-rw-r--r--pkgs/top-level/all-packages.nix1
-rw-r--r--pkgs/top-level/lua-packages.nix4
2 files changed, 3 insertions, 2 deletions
diff --git a/pkgs/top-level/all-packages.nix b/pkgs/top-level/all-packages.nix
index 0036c182be7f..65cae31a998e 100644
--- a/pkgs/top-level/all-packages.nix
+++ b/pkgs/top-level/all-packages.nix
@@ -13969,7 +13969,6 @@ with pkgs;
     inherit (darwin.apple_sdk.frameworks) ApplicationServices Carbon Cocoa;
     inherit (darwin.apple_sdk.libs) Xplugin;
     bootstrap_cmds = if stdenv.isDarwin then darwin.bootstrap_cmds else null;
-    python = python2; # Incompatible with Python 3x
     udev = if stdenv.isLinux then udev else null;
     libdrm = if stdenv.isLinux then libdrm else null;
     abiCompat = config.xorg.abiCompat # `config` because we have no `xorg.override`
diff --git a/pkgs/top-level/lua-packages.nix b/pkgs/top-level/lua-packages.nix
index 8d141d7e7c64..8a93f5dff5ba 100644
--- a/pkgs/top-level/lua-packages.nix
+++ b/pkgs/top-level/lua-packages.nix
@@ -596,7 +596,7 @@ let
     };
 
     patchPhase = stdenv.lib.optionalString stdenv.isDarwin ''
-      substituteInPlace src/makefile --replace gcc cc \
+      substituteInPlace src/makefile \
         --replace 10.3 10.5
     '';
 
@@ -604,6 +604,8 @@ let
       makeFlagsArray=(
         LUAV=${lua.luaversion}
         PLAT=${platformString}
+        CC=''${CC}
+        LD=''${CC}
         prefix=$out
       );
     '';