about summary refs log tree commit diff
path: root/pkgs/top-level
diff options
context:
space:
mode:
authorFrederik Rietdijk <fridh@fridh.nl>2018-01-24 16:10:08 +0100
committerFrederik Rietdijk <fridh@fridh.nl>2018-06-25 10:41:32 +0200
commit7c9d95fef59e2bc80fbde535df235a93d6690cc3 (patch)
treeae05e936d7b3a849a58ddc8077edafe092906c76 /pkgs/top-level
parentf799f12fb2939f57736e9cacad7d47ad1b163692 (diff)
downloadnixlib-7c9d95fef59e2bc80fbde535df235a93d6690cc3.tar
nixlib-7c9d95fef59e2bc80fbde535df235a93d6690cc3.tar.gz
nixlib-7c9d95fef59e2bc80fbde535df235a93d6690cc3.tar.bz2
nixlib-7c9d95fef59e2bc80fbde535df235a93d6690cc3.tar.lz
nixlib-7c9d95fef59e2bc80fbde535df235a93d6690cc3.tar.xz
nixlib-7c9d95fef59e2bc80fbde535df235a93d6690cc3.tar.zst
nixlib-7c9d95fef59e2bc80fbde535df235a93d6690cc3.zip
python37: init at 3.7.0rc1
Diffstat (limited to 'pkgs/top-level')
-rw-r--r--pkgs/top-level/all-packages.nix6
-rw-r--r--pkgs/top-level/python-packages.nix3
2 files changed, 8 insertions, 1 deletions
diff --git a/pkgs/top-level/all-packages.nix b/pkgs/top-level/all-packages.nix
index 871949df7bad..4ddb9f72cc99 100644
--- a/pkgs/top-level/all-packages.nix
+++ b/pkgs/top-level/all-packages.nix
@@ -7412,6 +7412,7 @@ with pkgs;
   python34Full = python34.override{x11Support=true;};
   python35Full = python35.override{x11Support=true;};
   python36Full = python36.override{x11Support=true;};
+  python37Full = python37.override{x11Support=true;};
 
   # pythonPackages further below, but assigned here because they need to be in sync
   pythonPackages = python.pkgs;
@@ -7434,6 +7435,10 @@ with pkgs;
     inherit (darwin) CF configd;
     self = python36;
   };
+  python37 = callPackage ../development/interpreters/python/cpython/3.7 {
+    inherit (darwin) CF configd;
+    self = python37;
+  };
 
   pypy27 = callPackage ../development/interpreters/python/pypy/2.7 {
     self = pypy27;
@@ -7446,6 +7451,7 @@ with pkgs;
   python34Packages = python34.pkgs;
   python35Packages = python35.pkgs;
   python36Packages = recurseIntoAttrs python36.pkgs;
+  python37Packages = python37.pkgs;
   pypyPackages = pypy.pkgs;
 
   # Should eventually be moved inside Python interpreters.
diff --git a/pkgs/top-level/python-packages.nix b/pkgs/top-level/python-packages.nix
index a47c17a5a87a..7bb82de095ca 100644
--- a/pkgs/top-level/python-packages.nix
+++ b/pkgs/top-level/python-packages.nix
@@ -26,6 +26,7 @@ let
   isPy34 = python.pythonVersion == "3.4";
   isPy35 = python.pythonVersion == "3.5";
   isPy36 = python.pythonVersion == "3.6";
+  isPy37 = python.pythonVersion == "3.7";
   isPyPy = python.executable == "pypy";
   isPy3k = strings.substring 0 1 python.pythonVersion == "3";
 
@@ -132,7 +133,7 @@ let
 
 in {
 
-  inherit python bootstrapped-pip pythonAtLeast pythonOlder isPy26 isPy27 isPy33 isPy34 isPy35 isPy36 isPyPy isPy3k buildPythonPackage buildPythonApplication;
+  inherit python bootstrapped-pip pythonAtLeast pythonOlder isPy26 isPy27 isPy33 isPy34 isPy35 isPy36 isPy37 isPyPy isPy3k buildPythonPackage buildPythonApplication;
   inherit fetchPypi callPackage;
   inherit hasPythonModule requiredPythonModules makePythonPath disabledIf;
   inherit toPythonModule toPythonApplication;