about summary refs log tree commit diff
path: root/pkgs/top-level
diff options
context:
space:
mode:
authorTuomas Tynkkynen <tuomas@tuxera.com>2016-02-05 00:47:23 +0200
committerTuomas Tynkkynen <tuomas@tuxera.com>2017-01-25 00:01:51 +0200
commit7c8a060c09799eb2ee70c00aa695ff08e5f07c6f (patch)
treed346e6bc9c7b2bf20d8c2240a66a2ff91fdaedfc /pkgs/top-level
parent41fd1ed90346a3d7f6b067301ac9e147ef4dcd5e (diff)
downloadnixlib-7c8a060c09799eb2ee70c00aa695ff08e5f07c6f.tar
nixlib-7c8a060c09799eb2ee70c00aa695ff08e5f07c6f.tar.gz
nixlib-7c8a060c09799eb2ee70c00aa695ff08e5f07c6f.tar.bz2
nixlib-7c8a060c09799eb2ee70c00aa695ff08e5f07c6f.tar.lz
nixlib-7c8a060c09799eb2ee70c00aa695ff08e5f07c6f.tar.xz
nixlib-7c8a060c09799eb2ee70c00aa695ff08e5f07c6f.tar.zst
nixlib-7c8a060c09799eb2ee70c00aa695ff08e5f07c6f.zip
stdenv: Bringup aarch64 architecture support
Diffstat (limited to 'pkgs/top-level')
-rw-r--r--pkgs/top-level/platforms.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/pkgs/top-level/platforms.nix b/pkgs/top-level/platforms.nix
index e6c55241b354..c740fbe6f8d1 100644
--- a/pkgs/top-level/platforms.nix
+++ b/pkgs/top-level/platforms.nix
@@ -443,12 +443,29 @@ rec {
     };
   };
 
+  aarch64-multiplatform = {
+    name = "aarch64-multiplatform";
+    kernelMajor = "2.6"; # Using "2.6" enables 2.6 kernel syscalls in glibc.
+    kernelHeadersBaseConfig = "defconfig";
+    kernelBaseConfig = "defconfig";
+    kernelArch = "arm64";
+    kernelDTB = true;
+    kernelAutoModules = false;
+    kernelExtraConfig = "";
+    uboot = null;
+    kernelTarget = "Image";
+    gcc = {
+      arch = "armv8-a";
+    };
+  };
+
   selectPlatformBySystem = system: {
       "i686-linux" = pc32;
       "x86_64-linux" = pc64;
       "armv5tel-linux" = sheevaplug;
       "armv6l-linux" = raspberrypi;
       "armv7l-linux" = armv7l-hf-multiplatform;
+      "aarch64-linux" = aarch64-multiplatform;
       "mips64el-linux" = fuloong2f_n32;
     }.${system} or pcBase;
 }