about summary refs log tree commit diff
path: root/pkgs/top-level
diff options
context:
space:
mode:
authorEelco Dolstra <edolstra@gmail.com>2020-04-02 18:01:45 +0200
committerEelco Dolstra <edolstra@gmail.com>2020-04-02 19:38:00 +0200
commit74e7ef35fee77139be31a3891033ff61496635f8 (patch)
tree6d27bcb517f7766e03d096d9c173aa2ed1466274 /pkgs/top-level
parent9737f249195db232178c3f7034e1c23220f4fcda (diff)
downloadnixlib-74e7ef35fee77139be31a3891033ff61496635f8.tar
nixlib-74e7ef35fee77139be31a3891033ff61496635f8.tar.gz
nixlib-74e7ef35fee77139be31a3891033ff61496635f8.tar.bz2
nixlib-74e7ef35fee77139be31a3891033ff61496635f8.tar.lz
nixlib-74e7ef35fee77139be31a3891033ff61496635f8.tar.xz
nixlib-74e7ef35fee77139be31a3891033ff61496635f8.tar.zst
nixlib-74e7ef35fee77139be31a3891033ff61496635f8.zip
nix-daemon.nix: Add option nix.registry
This allows you to specify the system-wide flake registry. One use is
to pin 'nixpkgs' to the Nixpkgs version used to build the system:

  nix.registry.nixpkgs.flake = nixpkgs;

where 'nixpkgs' is a flake input. This ensures that commands like

  $ nix run nixpkgs#hello

pull in a minimum of additional store paths.

You can also use this to redirect flakes, e.g.

  nix.registry.nixpkgs.to = {
    type = "github";
    owner = "my-org";
    repo = "my-nixpkgs";
  };
Diffstat (limited to 'pkgs/top-level')
-rw-r--r--pkgs/top-level/make-tarball.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/pkgs/top-level/make-tarball.nix b/pkgs/top-level/make-tarball.nix
index bb0d7bc54e78..6bb243879e9a 100644
--- a/pkgs/top-level/make-tarball.nix
+++ b/pkgs/top-level/make-tarball.nix
@@ -19,7 +19,7 @@ releaseTools.sourceTarball {
   version = pkgs.lib.fileContents ../../.version;
   versionSuffix = "pre${
     if nixpkgs ? lastModified
-    then builtins.substring 0 8 nixpkgs.lastModified
+    then builtins.substring 0 8 (nixpkgs.lastModifiedDate or nixpkgs.lastModified)
     else toString nixpkgs.revCount}.${nixpkgs.shortRev or "dirty"}";
 
   buildInputs = [ nix.out jq lib-tests pkgs.brotli ];