about summary refs log tree commit diff
path: root/pkgs/top-level
diff options
context:
space:
mode:
authorFrederik Rietdijk <fridh@fridh.nl>2017-05-07 09:30:47 +0200
committerFrederik Rietdijk <fridh@fridh.nl>2017-05-07 09:31:31 +0200
commit7491bc98e98dc58c7be6646f318525dfc96a8f88 (patch)
treec0323b7031a31b805cc5dd77e7614e515783c6e4 /pkgs/top-level
parent42cad8b6b00abfcd4e8627722d6bf84cd94a80b1 (diff)
downloadnixlib-7491bc98e98dc58c7be6646f318525dfc96a8f88.tar
nixlib-7491bc98e98dc58c7be6646f318525dfc96a8f88.tar.gz
nixlib-7491bc98e98dc58c7be6646f318525dfc96a8f88.tar.bz2
nixlib-7491bc98e98dc58c7be6646f318525dfc96a8f88.tar.lz
nixlib-7491bc98e98dc58c7be6646f318525dfc96a8f88.tar.xz
nixlib-7491bc98e98dc58c7be6646f318525dfc96a8f88.tar.zst
nixlib-7491bc98e98dc58c7be6646f318525dfc96a8f88.zip
pythonPackages: remove old unmaintained gsutil and dependencies
5bd5d2d9be5826793db8270befd1b064dcb49373 added gsutil and dependencies.
Since then, only f5680cdd49ef437da3faf3f9e1c999b0fef29b00 touched it.
There have been many updates since then of these packages. Because it is
not maintained I am removing this.
Diffstat (limited to 'pkgs/top-level')
-rw-r--r--pkgs/top-level/python-packages.nix50
1 files changed, 0 insertions, 50 deletions
diff --git a/pkgs/top-level/python-packages.nix b/pkgs/top-level/python-packages.nix
index f3dc153aad10..916bd3d058f6 100644
--- a/pkgs/top-level/python-packages.nix
+++ b/pkgs/top-level/python-packages.nix
@@ -28669,56 +28669,6 @@ EOF
     };
   };
 
-  boto-230 = buildPythonPackage rec {
-    name = "boto-2.30.0";
-    disabled = ! isPy27;
-    src = pkgs.fetchurl {
-      url = mirror://pypi/b/boto/boto-2.30.0.tar.gz;
-      sha256 = "12gl8azmx1vv8dbv9jhnsbhjpc2dd1ng0jlbcg734k6ggwq1h6hh";
-    };
-    doCheck = false;
-    meta = {
-      homepage = https://github.com/boto/boto;
-      license = licenses.mit;
-      description = "Python interface to Amazon Web Services";
-    };
-  };
-
-  gcs-oauth2-boto-plugin = buildPythonPackage rec {
-    name = "gcs-oauth2-boto-plugin-1.8";
-    disabled = ! isPy27;
-    src = pkgs.fetchurl {
-      url = mirror://pypi/g/gcs-oauth2-boto-plugin/gcs-oauth2-boto-plugin-1.8.tar.gz;
-      sha256 = "0jy62y5bmaf1mb735lqwry1s5nx2qqrxvl5sxip9yg4miih3qkyb";
-    };
-    propagatedBuildInputs = with self; [ boto-230 httplib2 google_api_python_client retry_decorator pyopenssl socksipy-branch ];
-    meta = {
-      homepage = https://developers.google.com/storage/docs/gspythonlibrary;
-      description = "Provides OAuth 2.0 credentials that can be used with Google Cloud Storage";
-      license = licenses.asl20;
-    };
-  };
-
-  gsutil = buildPythonPackage rec {
-    name = "gsutil-4.6";
-    disabled = ! isPy27;
-    meta = {
-      homepage = https://developers.google.com/storage/docs/gsutil;
-      description = "Google Cloud Storage Tool";
-      maintainers = with maintainers; [ roconnor ];
-      license = licenses.asl20;
-    };
-    doCheck = false;
-
-    src = pkgs.fetchurl {
-      url = mirror://pypi/g/gsutil/gsutil-4.6.tar.gz;
-      sha256 = "1i0clm60162rbk45ljr8nsw4ndkzjnwb7r440shcqjrvw8jq49mn";
-    };
-
-    propagatedBuildInputs = with self; [ boto-230 crcmod httplib2 gcs-oauth2-boto-plugin google_api_python_client gflags
-                                         retry_decorator pyopenssl socksipy-branch crcmod ];
-  };
-
   svg2tikz = self.buildPythonPackage {
     name = "svg2tikz-1.0.0";
     disabled = ! isPy27;