about summary refs log tree commit diff
path: root/pkgs/top-level
diff options
context:
space:
mode:
authorPeter Simons <simons@cryp.to>2014-01-21 20:29:34 +0100
committerPeter Simons <simons@cryp.to>2014-01-21 20:29:34 +0100
commit712458c3fca3ed19ae80221897fa3ecddc787337 (patch)
treeb79cb1a69c360fcff122ddd919731daa38850eae /pkgs/top-level
parent3d8b0401c2a202b1cf94240e4464c4888160236d (diff)
downloadnixlib-712458c3fca3ed19ae80221897fa3ecddc787337.tar
nixlib-712458c3fca3ed19ae80221897fa3ecddc787337.tar.gz
nixlib-712458c3fca3ed19ae80221897fa3ecddc787337.tar.bz2
nixlib-712458c3fca3ed19ae80221897fa3ecddc787337.tar.lz
nixlib-712458c3fca3ed19ae80221897fa3ecddc787337.tar.xz
nixlib-712458c3fca3ed19ae80221897fa3ecddc787337.tar.zst
nixlib-712458c3fca3ed19ae80221897fa3ecddc787337.zip
all-packages.nix: remove redundant texinfo5 overrides
Texinfo 5.x is the default version now.
Diffstat (limited to 'pkgs/top-level')
-rw-r--r--pkgs/top-level/all-packages.nix22
1 files changed, 8 insertions, 14 deletions
diff --git a/pkgs/top-level/all-packages.nix b/pkgs/top-level/all-packages.nix
index d4cfbe22ffa0..31290dc9cfaa 100644
--- a/pkgs/top-level/all-packages.nix
+++ b/pkgs/top-level/all-packages.nix
@@ -813,7 +813,6 @@ let
 
   docbook2x = callPackage ../tools/typesetting/docbook2x {
     inherit (perlPackages) XMLSAX XMLParser XMLNamespaceSupport;
-    texinfo = texinfo5;
   };
 
   dosfstools = callPackage ../tools/filesystems/dosfstools { };
@@ -1294,7 +1293,7 @@ let
 
   lxc = callPackage ../os-specific/linux/lxc { };
 
-  lzip = callPackage ../tools/compression/lzip { texinfo = texinfo5; };
+  lzip = callPackage ../tools/compression/lzip { };
 
   lzma = xz;
 
@@ -2257,7 +2256,6 @@ let
 
   bashInteractive = appendToName "interactive" (callPackage ../shells/bash {
     interactive = true;
-    texinfo = texinfo5;
   });
 
   bashCompletion = callPackage ../shells/bash-completion { };
@@ -4020,12 +4018,9 @@ let
 
   ffmpeg_1 = callPackage ../development/libraries/ffmpeg/1.x.nix {
     vpxSupport = !stdenv.isMips;
-    texinfo = texinfo5;
   };
 
-  ffmpeg_2 = callPackage ../development/libraries/ffmpeg/2.x.nix {
-    texinfo = texinfo5;
-  };
+  ffmpeg_2 = callPackage ../development/libraries/ffmpeg/2.x.nix { };
 
   ffmpeg = ffmpeg_2;
 
@@ -7576,7 +7571,6 @@ let
     librsvg = null;
     alsaLib = null;
     imagemagick = null;
-    texinfo = texinfo5;
 
     # use clangStdenv on darwin to deal with: unexec: 'my_edata is not in
     # section __data'
@@ -7594,7 +7588,7 @@ let
 
     autoComplete = callPackage ../applications/editors/emacs-modes/auto-complete { };
 
-    bbdb = callPackage ../applications/editors/emacs-modes/bbdb { texinfo = texinfo5; };
+    bbdb = callPackage ../applications/editors/emacs-modes/bbdb { };
 
     cedet = callPackage ../applications/editors/emacs-modes/cedet { };
 
@@ -7614,9 +7608,9 @@ let
 
     emacsSessionManagement = callPackage ../applications/editors/emacs-modes/session-management-for-emacs { };
 
-    emacsw3m = callPackage ../applications/editors/emacs-modes/emacs-w3m { texinfo = texinfo5; };
+    emacsw3m = callPackage ../applications/editors/emacs-modes/emacs-w3m { };
 
-    emms = callPackage ../applications/editors/emacs-modes/emms { texinfo = texinfo5; };
+    emms = callPackage ../applications/editors/emacs-modes/emms { };
 
     ess = callPackage ../applications/editors/emacs-modes/ess { };
 
@@ -7654,7 +7648,7 @@ let
 
     loremIpsum = callPackage ../applications/editors/emacs-modes/lorem-ipsum { };
 
-    magit = callPackage ../applications/editors/emacs-modes/magit { texinfo = texinfo5; };
+    magit = callPackage ../applications/editors/emacs-modes/magit { };
 
     maudeMode = callPackage ../applications/editors/emacs-modes/maude { };
 
@@ -7664,7 +7658,7 @@ let
 
     # This is usually a newer version of Org-Mode than that found in GNU Emacs, so
     # we want it to have higher precedence.
-    org = hiPrio (callPackage ../applications/editors/emacs-modes/org { texinfo = texinfo5; });
+    org = hiPrio (callPackage ../applications/editors/emacs-modes/org { };
 
     org2blog = callPackage ../applications/editors/emacs-modes/org2blog { };
 
@@ -10170,7 +10164,7 @@ let
 
   texLiveFull = lib.setName "texlive-full" (texLiveAggregationFun {
     paths = [ texLive texLiveExtra lmodern texLiveCMSuper texLiveLatexXColor
-              texLivePGF texLiveBeamer texLiveModerncv tipa tex4ht texinfo5
+              texLivePGF texLiveBeamer texLiveModerncv tipa tex4ht texinfo
               texLiveModerntimeline ];
   });