about summary refs log tree commit diff
path: root/pkgs/top-level
diff options
context:
space:
mode:
authorDmitry Kalinkin <dmitry.kalinkin@gmail.com>2020-06-06 14:24:13 -0400
committerDmitry Kalinkin <dmitry.kalinkin@gmail.com>2020-06-06 14:53:54 -0400
commit6fa6decdedfd65d5423b2299920dc83e66bdb89c (patch)
tree605556bf8ab693d20346ec9447b5c9dcf61074fd /pkgs/top-level
parentdfbc6b3a269699c9b0e05f83735532c6deca39b8 (diff)
downloadnixlib-6fa6decdedfd65d5423b2299920dc83e66bdb89c.tar
nixlib-6fa6decdedfd65d5423b2299920dc83e66bdb89c.tar.gz
nixlib-6fa6decdedfd65d5423b2299920dc83e66bdb89c.tar.bz2
nixlib-6fa6decdedfd65d5423b2299920dc83e66bdb89c.tar.lz
nixlib-6fa6decdedfd65d5423b2299920dc83e66bdb89c.tar.xz
nixlib-6fa6decdedfd65d5423b2299920dc83e66bdb89c.tar.zst
nixlib-6fa6decdedfd65d5423b2299920dc83e66bdb89c.zip
pythonPackages.geant4: init at 10.6.2
Starting geant4 10.6.2 g4py can not be built separately
http://geant4-data.web.cern.ch/geant4-data/ReleaseNotes/Patch4.10.6-2.txt

Also, it appears that g4py itself is now deprecated, it was moved
to environments/g4py/tests/g4pytest in the source distribution.  The only
remaining imported module is Geant4, hence python package name
`pythonPackages.geant4`, the capitalization matches the one of the non-python
attribute.
Diffstat (limited to 'pkgs/top-level')
-rw-r--r--pkgs/top-level/aliases.nix1
-rw-r--r--pkgs/top-level/all-packages.nix2
-rw-r--r--pkgs/top-level/python-packages.nix5
3 files changed, 6 insertions, 2 deletions
diff --git a/pkgs/top-level/aliases.nix b/pkgs/top-level/aliases.nix
index 1004a444469e..4f356a6a8415 100644
--- a/pkgs/top-level/aliases.nix
+++ b/pkgs/top-level/aliases.nix
@@ -153,6 +153,7 @@ mapAliases ({
   fuseki = apache-jena-fuseki; # added 2018-04-25
   fusesmb = throw "fusesmb is abandoned by upstream"; # added 2019-10-15
   fwupdate = throw "fwupdate was merged into fwupd"; # added 2020-05-19
+  g4py = python3Packages.geant4; # added 2020-06-06
   gccApple = throw "gccApple is no longer supported"; # added 2018-04-25
   gdb-multitarget = gdb; # added 2017-11-13
   gdk_pixbuf = gdk-pixbuf; # added 2019-05-22
diff --git a/pkgs/top-level/all-packages.nix b/pkgs/top-level/all-packages.nix
index bd298ce24ea2..38207e72127f 100644
--- a/pkgs/top-level/all-packages.nix
+++ b/pkgs/top-level/all-packages.nix
@@ -25344,8 +25344,6 @@ in
 
   cernlib = callPackage ../development/libraries/physics/cernlib { };
 
-  g4py = callPackage ../development/libraries/physics/geant4/g4py { };
-
   hepmc2 = callPackage ../development/libraries/physics/hepmc2 { };
 
   hepmc3 = callPackage ../development/libraries/physics/hepmc3 {
diff --git a/pkgs/top-level/python-packages.nix b/pkgs/top-level/python-packages.nix
index 00960b457252..ec27df8d71ce 100644
--- a/pkgs/top-level/python-packages.nix
+++ b/pkgs/top-level/python-packages.nix
@@ -3886,6 +3886,11 @@ in {
 
   gdrivefs = callPackage ../development/python-modules/gdrivefs { };
 
+  geant4 = disabledIf (!isPy3k) (toPythonModule (pkgs.geant4.override {
+    enablePython = true;
+    python3 = python;
+  }));
+
   genshi = callPackage ../development/python-modules/genshi { };
 
   gentools = callPackage ../development/python-modules/gentools { };