about summary refs log tree commit diff
path: root/pkgs/top-level
diff options
context:
space:
mode:
authorFrederik Rietdijk <fridh@fridh.nl>2019-01-01 11:34:44 +0100
committerFrederik Rietdijk <fridh@fridh.nl>2019-01-04 10:45:22 +0100
commit613498af978d65a7497cdd0dfd4f15c834348c61 (patch)
tree7110a8cae90214398b480efaae91922c50496dd1 /pkgs/top-level
parentefbe87f3ef769aac5e95512609b4759a43109307 (diff)
downloadnixlib-613498af978d65a7497cdd0dfd4f15c834348c61.tar
nixlib-613498af978d65a7497cdd0dfd4f15c834348c61.tar.gz
nixlib-613498af978d65a7497cdd0dfd4f15c834348c61.tar.bz2
nixlib-613498af978d65a7497cdd0dfd4f15c834348c61.tar.lz
nixlib-613498af978d65a7497cdd0dfd4f15c834348c61.tar.xz
nixlib-613498af978d65a7497cdd0dfd4f15c834348c61.tar.zst
nixlib-613498af978d65a7497cdd0dfd4f15c834348c61.zip
pypy: merge 2.7 and 3.5 into a single expression
This commit merges the two expressions in a single one, using
the passthru function that is shared with CPython.
Diffstat (limited to 'pkgs/top-level')
-rw-r--r--pkgs/top-level/all-packages.nix13
1 files changed, 1 insertions, 12 deletions
diff --git a/pkgs/top-level/all-packages.nix b/pkgs/top-level/all-packages.nix
index 34507b67b571..9b49b4f45e4f 100644
--- a/pkgs/top-level/all-packages.nix
+++ b/pkgs/top-level/all-packages.nix
@@ -7954,18 +7954,7 @@ in
   python3Packages = python3.pkgs;
 
   pythonInterpreters = callPackage ./../development/interpreters/python {};
-  inherit (pythonInterpreters) python27 python35 python36 python37;
-
-  pypy27 = callPackage ../development/interpreters/python/pypy/2.7 {
-    self = pypy27;
-    python = python27.override{x11Support=true;};
-    db = db.override { dbmSupport = true; };
-  };
-  pypy3 = callPackage ../development/interpreters/python/pypy/3 {
-    self = pypy3;
-    python = python27;
-    db = db.override { dbmSupport = true; };
-  };
+  inherit (pythonInterpreters) python27 python35 python36 python37 pypy27 pypy3;
 
   # Python package sets.
   python27Packages = lib.hiPrioSet (recurseIntoAttrs python27.pkgs);