about summary refs log tree commit diff
path: root/pkgs/top-level
diff options
context:
space:
mode:
authorwisut hantanong <wizzup@gmail.com>2017-07-19 16:32:53 +0700
committerwisut hantanong <wizzup@gmail.com>2017-07-19 16:32:53 +0700
commit5eea07391ea407b502dcd3b59c7c0f319c29b713 (patch)
tree6b143ac5e46ee96ed89929ffdb678bffa9c03250 /pkgs/top-level
parentaf02f13e2572a2bdde5a6e94e78f4f3dcc6a05a3 (diff)
downloadnixlib-5eea07391ea407b502dcd3b59c7c0f319c29b713.tar
nixlib-5eea07391ea407b502dcd3b59c7c0f319c29b713.tar.gz
nixlib-5eea07391ea407b502dcd3b59c7c0f319c29b713.tar.bz2
nixlib-5eea07391ea407b502dcd3b59c7c0f319c29b713.tar.lz
nixlib-5eea07391ea407b502dcd3b59c7c0f319c29b713.tar.xz
nixlib-5eea07391ea407b502dcd3b59c7c0f319c29b713.tar.zst
nixlib-5eea07391ea407b502dcd3b59c7c0f319c29b713.zip
python.pkgs.aiodns : move to separate expression
Diffstat (limited to 'pkgs/top-level')
-rw-r--r--pkgs/top-level/python-packages.nix25
1 files changed, 1 insertions, 24 deletions
diff --git a/pkgs/top-level/python-packages.nix b/pkgs/top-level/python-packages.nix
index 2a21ac792ae2..667d747582c9 100644
--- a/pkgs/top-level/python-packages.nix
+++ b/pkgs/top-level/python-packages.nix
@@ -278,30 +278,7 @@ in {
 
   afew = callPackage ../development/python-modules/afew { };
 
-  aiodns = buildPythonPackage rec {
-    name = "aiodns-${version}";
-    version = "1.0.1";
-
-    src = pkgs.fetchurl {
-      url = "mirror://pypi/a/aiodns/${name}.tar.gz";
-      sha256 = "595b78b8d54115d937cf60d778c02dad76b6f789fd527dab308f99e5601e7f3d";
-    };
-
-    propagatedBuildInputs = with self; [ pycares ] ++ optional isPy33 asyncio ++ optional (isPy26 || isPy27 || isPyPy) trollius;
-
-    checkPhase = ''
-      ${python.interpreter} tests.py
-    '';
-
-    # 'Could not contact DNS servers'
-    doCheck = false;
-
-    meta = {
-      homepage = http://github.com/saghul/aiodns;
-      license = licenses.mit;
-      description = "Simple DNS resolver for asyncio";
-    };
-  };
+  aiodns = callPackage ../development/python-modules/aiodns { };
 
   aiofiles = callPackage ../development/python-modules/aiofiles { };