about summary refs log tree commit diff
path: root/pkgs/top-level
diff options
context:
space:
mode:
authorPhilip Taron <philip.taron@gmail.com>2024-03-06 11:01:27 -0800
committerPhilip Taron <philip.taron@gmail.com>2024-03-08 14:55:07 -0800
commit5a64a05c666cc0fbabd4205c4382a47181d5af6d (patch)
treecc2ca36b04cb372080141f7b6eef1b85e409eb15 /pkgs/top-level
parent8a034c526ef48e395727c825041fe328e98416f8 (diff)
downloadnixlib-5a64a05c666cc0fbabd4205c4382a47181d5af6d.tar
nixlib-5a64a05c666cc0fbabd4205c4382a47181d5af6d.tar.gz
nixlib-5a64a05c666cc0fbabd4205c4382a47181d5af6d.tar.bz2
nixlib-5a64a05c666cc0fbabd4205c4382a47181d5af6d.tar.lz
nixlib-5a64a05c666cc0fbabd4205c4382a47181d5af6d.tar.xz
nixlib-5a64a05c666cc0fbabd4205c4382a47181d5af6d.tar.zst
nixlib-5a64a05c666cc0fbabd4205c4382a47181d5af6d.zip
Avoid top-level `with ...;` in pkgs/top-level/release-r.nix
Diffstat (limited to 'pkgs/top-level')
-rw-r--r--pkgs/top-level/release-r.nix8
1 files changed, 7 insertions, 1 deletions
diff --git a/pkgs/top-level/release-r.nix b/pkgs/top-level/release-r.nix
index 4c715a7786d6..898436de8cc4 100644
--- a/pkgs/top-level/release-r.nix
+++ b/pkgs/top-level/release-r.nix
@@ -6,7 +6,13 @@
 */
 { supportedSystems ? [ "x86_64-linux" "aarch64-linux" ] }:
 
-with import ./release-lib.nix { inherit supportedSystems; };
+let
+  inherit (import ./release-lib.nix { inherit supportedSystems; })
+    mapTestOn
+    packagePlatforms
+    pkgs
+    ;
+in
 
 mapTestOn {
   rPackages = packagePlatforms pkgs.rPackages;