about summary refs log tree commit diff
path: root/pkgs/top-level
diff options
context:
space:
mode:
authorBen Darwin <bcdarwin@gmail.com>2016-04-11 15:00:09 -0400
committerBen Darwin <bcdarwin@gmail.com>2016-04-11 15:00:09 -0400
commit5a2563c059309c0600404ce69f06a235fb717e4f (patch)
treef73945532c303a28e6403ac7fa0bd9f7dbc3df9b /pkgs/top-level
parenta2aec04abcd0887f073355b7cb63641fa4b42a51 (diff)
downloadnixlib-5a2563c059309c0600404ce69f06a235fb717e4f.tar
nixlib-5a2563c059309c0600404ce69f06a235fb717e4f.tar.gz
nixlib-5a2563c059309c0600404ce69f06a235fb717e4f.tar.bz2
nixlib-5a2563c059309c0600404ce69f06a235fb717e4f.tar.lz
nixlib-5a2563c059309c0600404ce69f06a235fb717e4f.tar.xz
nixlib-5a2563c059309c0600404ce69f06a235fb717e4f.tar.zst
nixlib-5a2563c059309c0600404ce69f06a235fb717e4f.zip
theano: init at 0.8.1
Diffstat (limited to 'pkgs/top-level')
-rw-r--r--pkgs/top-level/python-packages.nix30
1 files changed, 30 insertions, 0 deletions
diff --git a/pkgs/top-level/python-packages.nix b/pkgs/top-level/python-packages.nix
index c14372ea99bc..d10a64c588d7 100644
--- a/pkgs/top-level/python-packages.nix
+++ b/pkgs/top-level/python-packages.nix
@@ -20085,6 +20085,36 @@ in modules // {
     };
   };
 
+  Theano = buildPythonPackage rec {
+    name = "Theano-0.8.1";
+
+    disabled = isPyPy || pythonOlder "2.6" || (isPy3k && pythonOlder "3.3");
+
+    src = pkgs.fetchurl {
+      url = "https://pypi.python.org/packages/source/T/Theano/${name}.tar.gz";
+      sha256 = "17dikk94r8bzkxg976srqlhj5c7phs9gl837iabyfdpixkbrl79g";
+    };
+
+    #preCheck = ''
+    #  mkdir -p check-phase
+    #  export HOME=$(pwd)/check-phase
+    #'';
+    doCheck = false;
+    # takes far too long, also throws "TypeError: sort() missing 1 required positional argument: 'a'"
+    # when run from the installer, and testing with Python 3.5 hits github.com/Theano/Theano/issues/4276,
+    # the fix for which hasn't been merged yet.
+
+    # keep Nose around since running the tests by hand is possible from Python or bash
+    propagatedBuildInputs = [ stdenv pkgs.blas ] ++ (with self; [ nose numpy pydot_ng scipy six ]);
+
+    meta = {
+      homepage = http://deeplearning.net/software/theano/;
+      description = "A Python library for large-scale array computation";
+      license = stdenv.lib.licenses.bsd3;
+      maintainers = [ maintainers.bcdarwin ];
+    };
+  };
+
   tidylib = buildPythonPackage rec {
     version = "0.2.4";
     name = "pytidylib-${version}";