about summary refs log tree commit diff
path: root/pkgs/top-level
diff options
context:
space:
mode:
authorShea Levy <shea@shealevy.com>2014-01-20 05:23:17 -0500
committerShea Levy <shea@shealevy.com>2014-01-20 05:42:38 -0500
commit55e6303d6a0b943e72e6348867780f0886487871 (patch)
treec441051f3b50d14b7b69160314b551a1b9587562 /pkgs/top-level
parent86808f2c468703f96179ef788c8a750b47619696 (diff)
downloadnixlib-55e6303d6a0b943e72e6348867780f0886487871.tar
nixlib-55e6303d6a0b943e72e6348867780f0886487871.tar.gz
nixlib-55e6303d6a0b943e72e6348867780f0886487871.tar.bz2
nixlib-55e6303d6a0b943e72e6348867780f0886487871.tar.lz
nixlib-55e6303d6a0b943e72e6348867780f0886487871.tar.xz
nixlib-55e6303d6a0b943e72e6348867780f0886487871.tar.zst
nixlib-55e6303d6a0b943e72e6348867780f0886487871.zip
Add full llvm build, update libc++ and dragonegg
Some packages in the llvm suite (e.g. compiler-rt) cannot be built
separate from the build of llvm, and while some others (e.g. clang) can
the combined build is much better tested (we've had to work around
annoying issues before). So this puts llvm, clang, clang-tools-extra,
compiler-rt, lld, lldb, and polly all into one big build (llvmFull).
This build includes a static llvm, as dynamic is similarly less tested
and has known failures.

This also updates libc++ and dragonegg. libc++ now builds against
libc++abi as a separate package rather than building it during the
libc++ build.

The clang purity patch is gone. Instead, we simply set --sysroot to
/var/empty for pure builds, as all impure paths are either looked up in
the gcc prefix (which we hard-code at compile time) or in the sysroot.
This also means that if NIX_ENFORCE_PURITY is 0 then clang will look in
the normal Linux paths by default, which is the proper behavior IMO.

polly required an updated isl. When stdenv-updates is merged, perhaps we
can update the isl used by gcc and avoid having two versions.

Since llvm on its own is now separate from the llvm used by clang, I've
removed myself as maintainer from llvm and will leave maintenance of
that to those who are interested in llvm separate from clang.

Signed-off-by: Shea Levy <shea@shealevy.com>
Diffstat (limited to 'pkgs/top-level')
-rw-r--r--pkgs/top-level/all-packages.nix28
-rw-r--r--pkgs/top-level/release-python.nix1
2 files changed, 13 insertions, 16 deletions
diff --git a/pkgs/top-level/all-packages.nix b/pkgs/top-level/all-packages.nix
index 6c40c042f81b..39ce332ea879 100644
--- a/pkgs/top-level/all-packages.nix
+++ b/pkgs/top-level/all-packages.nix
@@ -1193,6 +1193,7 @@ let
   ised = callPackage ../tools/misc/ised {};
 
   isl = callPackage ../development/libraries/isl { };
+  isl_0_12 = callPackage ../development/libraries/isl/0.12.2.nix { };
 
   isync = callPackage ../tools/networking/isync { };
 
@@ -2298,18 +2299,10 @@ let
 
   ccl = builderDefsPackage ../development/compilers/ccl {};
 
-  clangUnwrapped = callPackage ../development/compilers/llvm/clang.nix {
-    stdenv = if stdenv.isDarwin
-      then stdenvAdapters.overrideGCC stdenv gccApple
-      else stdenvAdapters.overrideGCC stdenv gcc47;
-  };
-
-  clang = wrapClang clangUnwrapped;
+  clang = wrapClang llvmFull;
 
-  libcxxLLVM = callPackage ../development/compilers/llvm { stdenv = libcxxStdenv; version="3.3"; };
-  clangSelf = clangWrapSelf (callPackage ../development/compilers/llvm/clang.nix {
+  llvmFullSelf = clangWrapSelf (llvmFull.override {
      stdenv = libcxxStdenv;
-     llvm = libcxxLLVM;
   });
 
   clangWrapSelf = build: (import ../build-support/clang-wrapper) {
@@ -2325,7 +2318,7 @@ let
 
   #Use this instead of stdenv to build with clang
   clangStdenv = lowPrio (stdenvAdapters.overrideGCC stdenv clang);
-  libcxxStdenv = stdenvAdapters.overrideGCC stdenv (clangWrapSelf clangUnwrapped);
+  libcxxStdenv = stdenvAdapters.overrideGCC stdenv (clangWrapSelf llvmFull);
 
   clean = callPackage ../development/compilers/clean { };
 
@@ -2918,6 +2911,10 @@ let
       else stdenv;
   };
   llvm_33 = llvm_34.override { version = "3.3"; };
+  llvmFull = callPackage ../development/compilers/llvm/full.nix {
+    stdenv = stdenvAdapters.overrideGCC stdenv gcc47;
+    isl = isl_0_12;
+  };
 
   mentorToolchains = recurseIntoAttrs (
     callPackage_i686 ../development/compilers/mentor {}
@@ -3170,9 +3167,9 @@ let
   };
 
   wrapClangWith = clangWrapper: glibc: baseClang: clangWrapper {
-    nativeTools = stdenv ? gcc && stdenv.gcc.nativeTools;
-    nativeLibc = stdenv ? gcc && stdenv.gcc.nativeLibc;
-    nativePrefix = if stdenv ? gcc then stdenv.gcc.nativePrefix else "";
+    nativeTools = stdenv.gcc.nativeTools or false;
+    nativeLibc = stdenv.gcc.nativeLibc or false;
+    nativePrefix = stdenv.gcc.nativePrefix or "";
     clang = baseClang;
     libc = glibc;
     shell = bash;
@@ -3620,6 +3617,7 @@ let
   csslint = callPackage ../development/web/csslint { };
 
   libcxx = callPackage ../development/libraries/libc++ { stdenv = pkgs.clangStdenv; };
+  libcxxabi = callPackage ../development/libraries/libc++abi { stdenv = pkgs.clangStdenv; };
 
   dejagnu = callPackage ../development/tools/misc/dejagnu { };
 
@@ -4131,7 +4129,7 @@ let
 
   dssi = callPackage ../development/libraries/dssi {};
 
-  dragonegg = callPackage ../development/compilers/llvm/dragonegg.nix { };
+  dragonegg = callPackage ../development/compilers/llvm/dragonegg.nix { llvm = llvmFull; stdenv = overrideGCC stdenv gcc47; };
 
   dxflib = callPackage ../development/libraries/dxflib {};
 
diff --git a/pkgs/top-level/release-python.nix b/pkgs/top-level/release-python.nix
index aecb3c85aee8..e371d894ae1c 100644
--- a/pkgs/top-level/release-python.nix
+++ b/pkgs/top-level/release-python.nix
@@ -153,7 +153,6 @@ let
   cinepaint = { type = "job"; systems = ["x86_64-linux"]; schedulingPriority = 4; };
   ciopfs = { type = "job"; systems = ["x86_64-linux"]; schedulingPriority = 4; };
   clang = { type = "job"; systems = ["x86_64-linux"]; schedulingPriority = 4; };
-  clangUnwrapped = { type = "job"; systems = ["x86_64-linux"]; schedulingPriority = 4; };
   clanlib = { type = "job"; systems = ["x86_64-linux"]; schedulingPriority = 4; };
   classpath = { type = "job"; systems = ["x86_64-linux"]; schedulingPriority = 4; };
   clearsilver = { type = "job"; systems = ["x86_64-linux"]; schedulingPriority = 4; };