about summary refs log tree commit diff
path: root/pkgs/top-level
diff options
context:
space:
mode:
authorRobin Bate Boerop <me@robinbb.com>2016-03-26 14:53:23 -0300
committerJoachim Fasting <joachifm@fastmail.fm>2016-05-09 16:06:37 +0200
commit536d08cfbbf1ca2fef274798908a28fd8db22366 (patch)
treef749b4385b63640e0eae8d7a564e7eeb23559dd7 /pkgs/top-level
parent548108f8b55f621a50bc065b730e7568e9726e7d (diff)
downloadnixlib-536d08cfbbf1ca2fef274798908a28fd8db22366.tar
nixlib-536d08cfbbf1ca2fef274798908a28fd8db22366.tar.gz
nixlib-536d08cfbbf1ca2fef274798908a28fd8db22366.tar.bz2
nixlib-536d08cfbbf1ca2fef274798908a28fd8db22366.tar.lz
nixlib-536d08cfbbf1ca2fef274798908a28fd8db22366.tar.xz
nixlib-536d08cfbbf1ca2fef274798908a28fd8db22366.tar.zst
nixlib-536d08cfbbf1ca2fef274798908a28fd8db22366.zip
perlPackages.TestMockGuard: init at 0.10
Diffstat (limited to 'pkgs/top-level')
-rw-r--r--pkgs/top-level/perl-packages.nix14
1 files changed, 14 insertions, 0 deletions
diff --git a/pkgs/top-level/perl-packages.nix b/pkgs/top-level/perl-packages.nix
index 5fe3c14eb27a..73184669d9fa 100644
--- a/pkgs/top-level/perl-packages.nix
+++ b/pkgs/top-level/perl-packages.nix
@@ -12075,6 +12075,20 @@ let self = _self // overrides; _self = with self; {
     };
   };
 
+  TestMockGuard = buildPerlModule rec {
+    name = "Test-Mock-Guard-0.10";
+    src = fetchurl {
+      url = "mirror://cpan/authors/id/X/XA/XAICRON/${name}.tar.gz";
+      sha256 = "7f228a63f8d6ceb92aa784080a13e85073121b2835eca06d794f9709950dbd3d";
+    };
+    propagatedBuildInputs = [ ClassLoad ];
+    meta = {
+      homepage = https://github.com/zigorou/p5-test-mock-guard;
+      description = "Simple mock test library using RAII";
+      license = with stdenv.lib.licenses; [ artistic1 gpl1Plus ];
+    };
+  };
+
   TestMockModule = buildPerlModule {
     name = "Test-MockModule-0.11";
     src = fetchurl {