about summary refs log tree commit diff
path: root/pkgs/top-level
diff options
context:
space:
mode:
authorSong Wenwu <iyzsong@gmail.com>2014-01-08 16:39:05 +0800
committerRok Garbas <rok@garbas.si>2014-01-11 20:07:29 +0100
commit501008ad6f742c40888ef2b9ddf983373cd8d38a (patch)
tree9ece6f9d385d8e814e1ddaf9f17867eb47ac4744 /pkgs/top-level
parent98d2f7ea454fa09adfd16ac54bb90bd72eb9025c (diff)
downloadnixlib-501008ad6f742c40888ef2b9ddf983373cd8d38a.tar
nixlib-501008ad6f742c40888ef2b9ddf983373cd8d38a.tar.gz
nixlib-501008ad6f742c40888ef2b9ddf983373cd8d38a.tar.bz2
nixlib-501008ad6f742c40888ef2b9ddf983373cd8d38a.tar.lz
nixlib-501008ad6f742c40888ef2b9ddf983373cd8d38a.tar.xz
nixlib-501008ad6f742c40888ef2b9ddf983373cd8d38a.tar.zst
nixlib-501008ad6f742c40888ef2b9ddf983373cd8d38a.zip
pyqt4: update to 4.10.3 and add python3 support
also add python3 support for dbus-python
Diffstat (limited to 'pkgs/top-level')
-rw-r--r--pkgs/top-level/all-packages.nix2
-rw-r--r--pkgs/top-level/python-packages.nix12
2 files changed, 13 insertions, 1 deletions
diff --git a/pkgs/top-level/all-packages.nix b/pkgs/top-level/all-packages.nix
index 8c74a04f9b6d..0501d18ebee4 100644
--- a/pkgs/top-level/all-packages.nix
+++ b/pkgs/top-level/all-packages.nix
@@ -6191,7 +6191,7 @@ let
 
   sip = callPackage ../development/python-modules/sip { };
 
-  pyqt4 = callPackage ../development/python-modules/pyqt {
+  pyqt4 = callPackage ../development/python-modules/pyqt/4.x.nix {
     stdenv = if stdenv.isDarwin
       then clangStdenv
       else stdenv;
diff --git a/pkgs/top-level/python-packages.nix b/pkgs/top-level/python-packages.nix
index a9c678498762..60b7e00f019d 100644
--- a/pkgs/top-level/python-packages.nix
+++ b/pkgs/top-level/python-packages.nix
@@ -57,6 +57,11 @@ pythonPackages = modules // import ./python-packages-generated.nix {
 
   blivet = callPackage ../development/python-modules/blivet { };
 
+  dbus = import ../development/python-modules/dbus {
+    inherit (pkgs) stdenv fetchurl pkgconfig dbus dbus_glib dbus_tools;
+    inherit python;
+  };
+
   ipython = import ../shells/ipython {
     inherit (pkgs) stdenv fetchurl sip pyqt4;
     inherit buildPythonPackage pythonPackages;
@@ -121,6 +126,13 @@ pythonPackages = modules // import ./python-packages-generated.nix {
     inherit python buildPythonPackage pygobject pycairo;
   };
 
+  pyqt4 = import ../development/python-modules/pyqt/4.x.nix {
+    inherit (pkgs) stdenv fetchurl pkgconfig qt4 makeWrapper;
+    inherit (pkgs.xorg) lndir;
+    inherit python sip;
+    pythonDBus = dbus;
+  };
+
   sip = import ../development/python-modules/sip {
     inherit (pkgs) stdenv fetchurl;
     inherit python;