about summary refs log tree commit diff
path: root/pkgs/top-level
diff options
context:
space:
mode:
authorMichael Raskin <7c6f434c@mail.ru>2017-01-24 17:49:00 +0000
committerGitHub <noreply@github.com>2017-01-24 17:49:00 +0000
commit47661c831eed86c67976fa7b8277783b91904b89 (patch)
treea746472f43e6929d55dd59d098e87be864bf0600 /pkgs/top-level
parent89278345c20c14c349c4148efc01d1c900e942c3 (diff)
parentde4c9e0d1569fe61e973c9889ef36cb285bde406 (diff)
downloadnixlib-47661c831eed86c67976fa7b8277783b91904b89.tar
nixlib-47661c831eed86c67976fa7b8277783b91904b89.tar.gz
nixlib-47661c831eed86c67976fa7b8277783b91904b89.tar.bz2
nixlib-47661c831eed86c67976fa7b8277783b91904b89.tar.lz
nixlib-47661c831eed86c67976fa7b8277783b91904b89.tar.xz
nixlib-47661c831eed86c67976fa7b8277783b91904b89.tar.zst
nixlib-47661c831eed86c67976fa7b8277783b91904b89.zip
Merge pull request #22028 from MostAwesomeDude/tahoe
Tahoe-LAFS version bump
Diffstat (limited to 'pkgs/top-level')
-rw-r--r--pkgs/top-level/python-packages.nix22
1 files changed, 18 insertions, 4 deletions
diff --git a/pkgs/top-level/python-packages.nix b/pkgs/top-level/python-packages.nix
index d6456c13645a..061dcd68f9b6 100644
--- a/pkgs/top-level/python-packages.nix
+++ b/pkgs/top-level/python-packages.nix
@@ -11778,14 +11778,21 @@ in {
   });
 
   foolscap = buildPythonPackage (rec {
-    name = "foolscap-0.10.1";
+    name = "foolscap-${version}";
+    version = "0.12.6";
 
     src = pkgs.fetchurl {
-      url = "http://foolscap.lothar.com/releases/${name}.tar.gz";
-      sha256 = "1wrnbdq3y3lfxnhx30yj9xbr3iy9512jb60k8qi1da1phalnwz5x";
+      url = "mirror://pypi/f/foolscap/${name}.tar.gz";
+      sha256 = "1bpmqq6485mmr5jza9q2c55l9m1bfsvsbd9drsip7p5qcsi22jrz";
     };
 
-    propagatedBuildInputs = [ self.twisted self.pyopenssl self.service-identity ];
+    propagatedBuildInputs = with self; [ mock twisted pyopenssl service-identity ];
+
+    checkPhase = ''
+      # Either uncomment this, or remove this custom check phase entirely, if
+      # you wish to do battle with the foolscap tests. ~ C.
+      # trial foolscap
+    '';
 
     meta = {
       homepage = http://foolscap.lothar.com/;
@@ -26096,6 +26103,13 @@ in {
 
     propagatedBuildInputs = with self; [ zope_interface ];
 
+    # Patch t.p._inotify to point to libc. Without this,
+    # twisted.python.runtime.platform.supportsINotify() == False
+    patchPhase = optionalString stdenv.isLinux ''
+      substituteInPlace twisted/python/_inotify.py --replace \
+        "ctypes.util.find_library('c')" "'${stdenv.glibc.out}/lib/libc.so.6'"
+    '';
+
     # Generate Twisted's plug-in cache.  Twisted users must do it as well.  See
     # http://twistedmatrix.com/documents/current/core/howto/plugin.html#auto3
     # and http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=477103 for