about summary refs log tree commit diff
path: root/pkgs/top-level
diff options
context:
space:
mode:
authorvolth <volth@volth.com>2018-06-04 16:08:54 +0000
committervolth <volth@volth.com>2018-06-04 16:08:54 +0000
commit474390ab95551a76e4041abe886ec8f9f5643c4f (patch)
treee8bb5321bf9c46588862106280b42990cf51040c /pkgs/top-level
parent8e17ad4d6393bdb502b97566e2afced40a41b784 (diff)
downloadnixlib-474390ab95551a76e4041abe886ec8f9f5643c4f.tar
nixlib-474390ab95551a76e4041abe886ec8f9f5643c4f.tar.gz
nixlib-474390ab95551a76e4041abe886ec8f9f5643c4f.tar.bz2
nixlib-474390ab95551a76e4041abe886ec8f9f5643c4f.tar.lz
nixlib-474390ab95551a76e4041abe886ec8f9f5643c4f.tar.xz
nixlib-474390ab95551a76e4041abe886ec8f9f5643c4f.tar.zst
nixlib-474390ab95551a76e4041abe886ec8f9f5643c4f.zip
[cpan2nix] perlPackages.Appperlbrew: 0.82 -> 0.83
dependencies:
perlPackages.TestTempDirTiny: init at 0.017
Diffstat (limited to 'pkgs/top-level')
-rw-r--r--pkgs/top-level/perl-packages.nix21
1 files changed, 17 insertions, 4 deletions
diff --git a/pkgs/top-level/perl-packages.nix b/pkgs/top-level/perl-packages.nix
index e9f6364a7478..c76a130686ce 100644
--- a/pkgs/top-level/perl-packages.nix
+++ b/pkgs/top-level/perl-packages.nix
@@ -312,13 +312,13 @@ let self = _self // overrides; _self = with self; {
     };
   };
 
-  Appperlbrew = buildPerlPackage rec {
-    name = "App-perlbrew-0.82";
+  Appperlbrew = buildPerlModule rec {
+    name = "App-perlbrew-0.83";
     src = fetchurl {
       url = "mirror://cpan/authors/id/G/GU/GUGOD/${name}.tar.gz";
-      sha256 = "0p6l5i85zp89f5sh0gyz7didla672zg169yprbqcf97icmr46g80";
+      sha256 = "0sdz0y90pk49cw4njfm1jq7zppha6kdx7i1d6nk41672nqrphdhb";
     };
-    buildInputs = [ pkgs.curl FileWhich IOAll PathClass PodMarkdown TestException TestNoWarnings TestOutput TestSpec ];
+    buildInputs = [ pkgs.curl FileWhich IOAll ModuleBuildTiny PathClass PodMarkdown TestException TestNoWarnings TestOutput TestSpec TestTempDirTiny ];
     propagatedBuildInputs = [ CPANPerlReleases CaptureTiny DevelPatchPerl PodUsage locallib ];
 
     preConfigure = ''
@@ -15978,6 +15978,19 @@ let self = _self // overrides; _self = with self; {
     };
   };
 
+  TestTempDirTiny = buildPerlPackage rec {
+    name = "Test-TempDir-Tiny-0.017";
+    src = fetchurl {
+      url = mirror://cpan/authors/id/D/DA/DAGOLDEN/Test-TempDir-Tiny-0.017.tar.gz;
+      sha256 = "0y2km1lbvp4hhsah2yc8vacp705zi1ijflsf7lkvqh640q6p5m55";
+    };
+    meta = {
+      description = "Temporary directories that stick around when tests fail";
+      license = with stdenv.lib.licenses; [ asl20 ];
+      homepage = "https://github.com/dagolden/Test-TempDir-Tiny";
+    };
+  };
+
   TestTCP = buildPerlPackage rec {
     name = "Test-TCP-2.19";
     src = fetchurl {