about summary refs log tree commit diff
path: root/pkgs/top-level
diff options
context:
space:
mode:
authorElis Hirwing <elis@hirwing.se>2020-04-29 19:56:37 +0200
committerGitHub <noreply@github.com>2020-04-29 19:56:37 +0200
commit410c38f3171c6d6f2dc6de9e4766e41f46a52a94 (patch)
treeb327659ca9da42dba44240a42a7c3f5b56e9ed20 /pkgs/top-level
parent3b21abb3d3353d4be767f53db216f65cc8048551 (diff)
downloadnixlib-410c38f3171c6d6f2dc6de9e4766e41f46a52a94.tar
nixlib-410c38f3171c6d6f2dc6de9e4766e41f46a52a94.tar.gz
nixlib-410c38f3171c6d6f2dc6de9e4766e41f46a52a94.tar.bz2
nixlib-410c38f3171c6d6f2dc6de9e4766e41f46a52a94.tar.lz
nixlib-410c38f3171c6d6f2dc6de9e4766e41f46a52a94.tar.xz
nixlib-410c38f3171c6d6f2dc6de9e4766e41f46a52a94.tar.zst
nixlib-410c38f3171c6d6f2dc6de9e4766e41f46a52a94.zip
Revert "PHP maintainer team"
Diffstat (limited to 'pkgs/top-level')
-rw-r--r--pkgs/top-level/php-packages.nix81
1 files changed, 17 insertions, 64 deletions
diff --git a/pkgs/top-level/php-packages.nix b/pkgs/top-level/php-packages.nix
index 35c0312e34dc..0cda058459df 100644
--- a/pkgs/top-level/php-packages.nix
+++ b/pkgs/top-level/php-packages.nix
@@ -51,7 +51,7 @@ in
         description = "An application for building and managing Phars";
         license = licenses.mit;
         homepage = "https://box-project.github.io/box2/";
-        maintainers = with maintainers; [ jtojnar ] ++ teams.php.members;
+        maintainers = with maintainers; [ jtojnar ];
       };
     };
 
@@ -80,7 +80,7 @@ in
         description = "Dependency Manager for PHP";
         license = licenses.mit;
         homepage = "https://getcomposer.org/";
-        maintainers = with maintainers; [ offline ] ++ teams.php.members;
+        maintainers = with maintainers; [ globin offline ];
       };
     };
 
@@ -107,7 +107,7 @@ in
         description = "A tool to automatically fix PHP coding standards issues";
         license = licenses.mit;
         homepage = "http://cs.sensiolabs.org/";
-        maintainers = with maintainers; [ jtojnar ] ++ teams.php.members;
+        maintainers = with maintainers; [ jtojnar ];
       };
     };
 
@@ -144,7 +144,7 @@ in
         description = "This tool check syntax of PHP files faster than serial check with fancier output";
         license = licenses.bsd2;
         homepage = "https://github.com/JakubOnderka/PHP-Parallel-Lint";
-        maintainers = with maintainers; [ jtojnar ] ++ teams.php.members;
+        maintainers = with maintainers; [ jtojnar ];
       };
     };
 
@@ -171,7 +171,7 @@ in
         description = "PHP coding standard beautifier and fixer";
         license = licenses.bsd3;
         homepage = "https://squizlabs.github.io/PHP_CodeSniffer/";
-        maintainers = with maintainers; [ cmcdragonkai ] ++ teams.php.members;
+        maintainers = with maintainers; [ cmcdragonkai etu ];
       };
     };
 
@@ -198,7 +198,7 @@ in
         description = "PHP coding standard tool";
         license = licenses.bsd3;
         homepage = "https://squizlabs.github.io/PHP_CodeSniffer/";
-        maintainers = with maintainers; [ javaguirre ] ++ teams.php.members;
+        maintainers = with maintainers; [ javaguirre etu ];
       };
     };
 
@@ -224,15 +224,15 @@ in
       meta = with pkgs.lib; {
         description = "PHP Static Analysis Tool";
         longDescription = ''
-          PHPStan focuses on finding errors in your code without actually
-          running it. It catches whole classes of bugs even before you write
-          tests for the code. It moves PHP closer to compiled languages in the
-          sense that the correctness of each line of the code can be checked
-          before you run the actual line.
-        '';
+        PHPStan focuses on finding errors in your code without actually running
+        it. It catches whole classes of bugs even before you write tests for the
+        code. It moves PHP closer to compiled languages in the sense that the
+        correctness of each line of the code can be checked before you run the
+        actual line.
+      '';
         license = licenses.mit;
         homepage = "https://github.com/phpstan/phpstan";
-        maintainers = teams.php.members;
+        maintainers = with maintainers; [ etu ];
       };
     };
 
@@ -259,7 +259,6 @@ in
         description = "A static analysis tool for finding errors in PHP applications";
         license = licenses.mit;
         homepage = "https://github.com/vimeo/psalm";
-        maintainers = teams.php.members;
       };
     };
 
@@ -286,7 +285,7 @@ in
         description = "PsySH is a runtime developer console, interactive debugger and REPL for PHP.";
         license = licenses.mit;
         homepage = "https://psysh.org/";
-        maintainers = with maintainers; [ caugner ] ++ teams.php.members;
+        maintainers = with maintainers; [ caugner ];
       };
     };
   };
@@ -309,8 +308,6 @@ in
       checkFlagsArray = ["REPORT_EXIT_STATUS=1" "NO_INTERACTION=1"];
       makeFlags = [ "phpincludedir=$(dev)/include" ];
       outputs = [ "out" "dev" ];
-
-      meta.maintainers = lib.teams.php.members;
     };
 
     apcu_bc = buildPecl {
@@ -323,8 +320,6 @@ in
         php.extensions.apcu
         pcre'
       ];
-
-      meta.maintainers = lib.teams.php.members;
     };
 
     ast = buildPecl {
@@ -332,8 +327,6 @@ in
       pname = "ast";
 
       sha256 = "16c5isldm4csjbcvz1qk2mmrhgvh24sxsp6w6f5a37xpa3vciawp";
-
-      meta.maintainers = lib.teams.php.members;
     };
 
     couchbase = buildPecl rec {
@@ -381,7 +374,6 @@ in
         '')
       ];
 
-      meta.maintainers = lib.teams.php.members;
       meta.broken = isPhp74; # Build error
     };
 
@@ -414,7 +406,6 @@ in
         '';
         license = licenses.php301;
         homepage = "https://bitbucket.org/osmanov/pecl-event/";
-        maintainers = teams.php.members;
       };
     };
 
@@ -427,8 +418,6 @@ in
       configureFlags = [ "--enable-igbinary" ];
       makeFlags = [ "phpincludedir=$(dev)/include" ];
       outputs = [ "out" "dev" ];
-
-      meta.maintainers = lib.teams.php.members;
     };
 
     imagick = buildPecl {
@@ -440,8 +429,6 @@ in
       configureFlags = [ "--with-imagick=${pkgs.imagemagick.dev}" ];
       nativeBuildInputs = [ pkgs.pkgconfig ];
       buildInputs = [ pcre' ];
-
-      meta.maintainers = lib.teams.php.members;
     };
 
     mailparse = buildPecl {
@@ -453,8 +440,6 @@ in
       postConfigure = ''
         echo "#define HAVE_MBSTRING 1" >> config.h
       '';
-
-      meta.maintainers = lib.teams.php.members;
     };
 
     maxminddb = buildPecl rec {
@@ -474,7 +459,7 @@ in
       meta = with pkgs.lib; {
         description = "C extension that is a drop-in replacement for MaxMind\\Db\\Reader";
         license = with licenses; [ asl20 ];
-        maintainers = with maintainers; [ ajs124 das_j ] ++ teams.php.members;
+        maintainers = with maintainers; [ ajs124 das_j ];
       };
     };
 
@@ -501,8 +486,6 @@ in
 
       nativeBuildInputs = [ pkgs.pkgconfig ];
       buildInputs = with pkgs; [ cyrus_sasl zlib ];
-
-      meta.maintainers = lib.teams.php.members;
     };
 
     mongodb = buildPecl {
@@ -520,8 +503,6 @@ in
         zlib
         pcre'
       ] ++ lib.optional (pkgs.stdenv.isDarwin) pkgs.darwin.apple_sdk.frameworks.Security;
-
-      meta.maintainers = lib.teams.php.members;
     };
 
     oci8 = buildPecl {
@@ -535,8 +516,6 @@ in
       postPatch = ''
         sed -i -e 's|OCISDKMANINC=`.*$|OCISDKMANINC="${pkgs.oracle-instantclient.dev}/include"|' config.m4
       '';
-
-      meta.maintainers = lib.teams.php.members;
     };
 
     pcov = buildPecl {
@@ -546,8 +525,6 @@ in
       sha256 = "1psfwscrc025z8mziq69pcx60k4fbkqa5g2ia8lplb94mmarj0v1";
 
       buildInputs = [ pcre' ];
-
-      meta.maintainers = lib.teams.php.members;
     };
 
     pcs = buildPecl {
@@ -556,7 +533,6 @@ in
 
       sha256 = "0d4p1gpl8gkzdiv860qzxfz250ryf0wmjgyc8qcaaqgkdyh5jy5p";
 
-      meta.maintainers = lib.teams.php.members;
       meta.broken = isPhp74; # Build error
     };
 
@@ -572,10 +548,8 @@ in
       internalDeps = [ php.extensions.pdo ];
 
       postPatch = ''
-        sed -i -e 's|OCISDKMANINC=`.*$|OCISDKMANINC="${pkgs.oracle-instantclient.dev}/include"|' config.m4
-      '';
-
-      meta.maintainers = lib.teams.php.members;
+      sed -i -e 's|OCISDKMANINC=`.*$|OCISDKMANINC="${pkgs.oracle-instantclient.dev}/include"|' config.m4
+    '';
     };
 
     pdo_sqlsrv = buildPecl {
@@ -587,8 +561,6 @@ in
       internalDeps = [ php.extensions.pdo ];
 
       buildInputs = [ pkgs.unixODBC ] ++ pkgs.lib.optionals pkgs.stdenv.isDarwin [ pkgs.libiconv ];
-
-      meta.maintainers = lib.teams.php.members;
     };
 
     php_excel = buildPecl rec {
@@ -604,8 +576,6 @@ in
       };
 
       configureFlags = [ "--with-excel" "--with-libxl-incdir=${pkgs.libxl}/include_c" "--with-libxl-libdir=${pkgs.libxl}/lib" ];
-
-      meta.maintainers = lib.teams.php.members;
     };
 
     pinba = let
@@ -631,7 +601,6 @@ in
           statistics server for PHP using MySQL as a read-only interface.
         '';
         homepage = "http://pinba.org/";
-        maintainers = teams.php.members;
       };
     };
 
@@ -649,7 +618,6 @@ in
         '';
         license = licenses.bsd3;
         homepage = "https://developers.google.com/protocol-buffers/";
-        maintainers = teams.php.members;
       };
     };
 
@@ -685,8 +653,6 @@ in
         session
       ] ++ lib.optionals (lib.versionOlder php.version "7.4") [
         hash ];
-
-      meta.maintainers = lib.teams.php.members;
     };
 
     sqlsrv = buildPecl {
@@ -696,8 +662,6 @@ in
       sha256 = "1kv4krk1w4hri99b0sdgwgy9c4y0yh217wx2y3irhkfi46kdrjnw";
 
       buildInputs = [ pkgs.unixODBC ] ++ pkgs.lib.optionals pkgs.stdenv.isDarwin [ pkgs.libiconv ];
-
-      meta.maintainers = lib.teams.php.members;
     };
 
     v8 = buildPecl {
@@ -708,8 +672,6 @@ in
 
       buildInputs = [ pkgs.v8_6_x ];
       configureFlags = [ "--with-v8=${pkgs.v8_6_x}" ];
-
-      meta.maintainers = lib.teams.php.members;
       meta.broken = true;
     };
 
@@ -721,8 +683,6 @@ in
 
       buildInputs = [ pkgs.v8_6_x ];
       configureFlags = [ "--with-v8js=${pkgs.v8_6_x}" ];
-
-      meta.maintainers = lib.teams.php.members;
       meta.broken = true;
     };
 
@@ -736,8 +696,6 @@ in
       checkTarget = "test";
 
       zendExtension = true;
-
-      meta.maintainers = lib.teams.php.members;
     };
 
     yaml = buildPecl {
@@ -751,8 +709,6 @@ in
       ];
 
       nativeBuildInputs = [ pkgs.pkgconfig ];
-
-      meta.maintainers = lib.teams.php.members;
     };
 
     zmq = buildPecl {
@@ -767,7 +723,6 @@ in
 
       nativeBuildInputs = [ pkgs.pkgconfig ];
 
-      meta.maintainers = lib.teams.php.members;
       meta.broken = isPhp73;
     };
   } // (let
@@ -827,8 +782,6 @@ in
                               --prune-empty-dirs \
                               . $dev/include/
       '';
-
-      meta.maintainers = lib.teams.php.members;
     });
 
     # This list contains build instructions for different modules that one may