about summary refs log tree commit diff
path: root/pkgs/top-level
diff options
context:
space:
mode:
authorGuillaume Maudoux <layus.on@gmail.com>2016-06-21 23:04:50 +0200
committerGuillaume Maudoux <layus.on@gmail.com>2016-06-21 23:04:50 +0200
commit3b4a4428cae65c2c8a923a156d8a10c6693f61e7 (patch)
tree9b9abefc41f6baa687e6012f42e0a77fe216972f /pkgs/top-level
parent6a61621cb4e93ff50b5dac7dc8900acc55184ed1 (diff)
downloadnixlib-3b4a4428cae65c2c8a923a156d8a10c6693f61e7.tar
nixlib-3b4a4428cae65c2c8a923a156d8a10c6693f61e7.tar.gz
nixlib-3b4a4428cae65c2c8a923a156d8a10c6693f61e7.tar.bz2
nixlib-3b4a4428cae65c2c8a923a156d8a10c6693f61e7.tar.lz
nixlib-3b4a4428cae65c2c8a923a156d8a10c6693f61e7.tar.xz
nixlib-3b4a4428cae65c2c8a923a156d8a10c6693f61e7.tar.zst
nixlib-3b4a4428cae65c2c8a923a156d8a10c6693f61e7.zip
python-lti: pin mock dependency at 1.0.1
Diffstat (limited to 'pkgs/top-level')
-rw-r--r--pkgs/top-level/python-packages.nix13
1 files changed, 11 insertions, 2 deletions
diff --git a/pkgs/top-level/python-packages.nix b/pkgs/top-level/python-packages.nix
index e0669abd2186..2d61728a551b 100644
--- a/pkgs/top-level/python-packages.nix
+++ b/pkgs/top-level/python-packages.nix
@@ -6965,7 +6965,16 @@ in modules // {
     };
   };
 
-  lti = let self' = (self.override {self = self';}) // {pytest = self.pytest_27;};
+  lti = let
+    self' = (self.override {self = self';}) // {pytest = self.pytest_27;};
+    mock_1_0_1 = self'.mock.overrideDerivation (_: rec {
+      name = "mock-1.0.1";
+      propagatedBuildInputs = null;
+      src = pkgs.fetchurl {
+        url = "http://pypi.python.org/packages/source/m/mock/${name}.tar.gz";
+        sha256 = "0kzlsbki6q0awf89rc287f3aj8x431lrajf160a70z0ikhnxsfdq";
+      };
+    });
   in buildPythonPackage rec {
     version = "0.4.1";
     name = "PyLTI-${version}";
@@ -6975,7 +6984,7 @@ in modules // {
     propagatedBuildInputs = with self; [ httplib2 oauth oauth2 semantic-version ];
     buildInputs = with self'; [
       flask httpretty oauthlib pyflakes pytest pytestcache pytestcov covCore
-      pytestflakes pytestpep8 sphinx mock
+      pytestflakes pytestpep8 sphinx mock_1_0_1
     ];
 
     src = pkgs.fetchurl {