about summary refs log tree commit diff
path: root/pkgs/top-level
diff options
context:
space:
mode:
authorFrederik Rietdijk <fridh@fridh.nl>2017-05-27 17:22:11 +0200
committerFrederik Rietdijk <fridh@fridh.nl>2017-05-27 17:22:11 +0200
commit2ff488c267a873ba583d0bafbb27b166eea53893 (patch)
treefb7063364634bf9d81c219f258a4a4c35555461c /pkgs/top-level
parent6b999f3c42607342231b6fe119fcf0f934f40fd8 (diff)
downloadnixlib-2ff488c267a873ba583d0bafbb27b166eea53893.tar
nixlib-2ff488c267a873ba583d0bafbb27b166eea53893.tar.gz
nixlib-2ff488c267a873ba583d0bafbb27b166eea53893.tar.bz2
nixlib-2ff488c267a873ba583d0bafbb27b166eea53893.tar.lz
nixlib-2ff488c267a873ba583d0bafbb27b166eea53893.tar.xz
nixlib-2ff488c267a873ba583d0bafbb27b166eea53893.tar.zst
nixlib-2ff488c267a873ba583d0bafbb27b166eea53893.zip
python.pkgs.django_hijack
Get rid of overriding inside the fixed-point combinator. Overriding
versions inside the set causes trouble when combining packages.
Diffstat (limited to 'pkgs/top-level')
-rw-r--r--pkgs/top-level/python-packages.nix10
1 files changed, 4 insertions, 6 deletions
diff --git a/pkgs/top-level/python-packages.nix b/pkgs/top-level/python-packages.nix
index 0cc9820f4c12..39eb87853975 100644
--- a/pkgs/top-level/python-packages.nix
+++ b/pkgs/top-level/python-packages.nix
@@ -10193,6 +10193,9 @@ in {
     };
   };
 
+  # This package likely needs an older version of Django.
+  # Override the package set and set e.g. `django = super.django_1_9`.
+  # See the Nixpkgs manual for examples on how to override the package set.
   django_hijack = buildPythonPackage rec {
     name = "django-hijack-${version}";
     version = "2.0.7";
@@ -10202,12 +10205,7 @@ in {
       sha256 = "0rpi1bkfx74xfbb2nk874kfdra1jcqp2vzky1r3z7zidlc9kah04";
     };
 
-    # TODO improve the that multi-override necessity (the fixpoint based python
-    # packages work can be the solution)
-    propagatedBuildInputs = with self; [ django_1_9 (django_compat.override {
-      django = django_1_9;
-      django_nose = django_nose.override { propagatedBuildInputs = [django_1_9 nose]; };
-    }) ];
+    propagatedBuildInputs = with self; [ django django_compat ];
 
     meta = {
       description = "Allows superusers to hijack (=login as) and work on behalf of another user";