about summary refs log tree commit diff
path: root/pkgs/top-level
diff options
context:
space:
mode:
authorFelix Buehler <account@buehler.rocks>2024-01-03 22:05:32 +0100
committerFelix Buehler <account@buehler.rocks>2024-01-03 22:05:32 +0100
commit2661df19851e742dde5deb2e224e194772b9b9e5 (patch)
tree0e2590fe68158bafacfa51595d6cb3890db1c46b /pkgs/top-level
parent92ffd1046a48a908e3f87d681afce6852e26a9e7 (diff)
downloadnixlib-2661df19851e742dde5deb2e224e194772b9b9e5.tar
nixlib-2661df19851e742dde5deb2e224e194772b9b9e5.tar.gz
nixlib-2661df19851e742dde5deb2e224e194772b9b9e5.tar.bz2
nixlib-2661df19851e742dde5deb2e224e194772b9b9e5.tar.lz
nixlib-2661df19851e742dde5deb2e224e194772b9b9e5.tar.xz
nixlib-2661df19851e742dde5deb2e224e194772b9b9e5.tar.zst
nixlib-2661df19851e742dde5deb2e224e194772b9b9e5.zip
fastnlo-toolkit,python311Packages.fastnlo-toolkit: rename from fastnlo_toolkit
Diffstat (limited to 'pkgs/top-level')
-rw-r--r--pkgs/top-level/aliases.nix3
-rw-r--r--pkgs/top-level/all-packages.nix2
-rw-r--r--pkgs/top-level/python-aliases.nix1
-rw-r--r--pkgs/top-level/python-packages.nix2
4 files changed, 5 insertions, 3 deletions
diff --git a/pkgs/top-level/aliases.nix b/pkgs/top-level/aliases.nix
index 79c739e47f89..6ec13a36675d 100644
--- a/pkgs/top-level/aliases.nix
+++ b/pkgs/top-level/aliases.nix
@@ -261,7 +261,8 @@ mapAliases ({
   ### F ###
 
   faustStk = faustPhysicalModeling; # Added 2023-05-16
-  fastnlo = fastnlo_toolkit; # Added 2021-04-24
+  fastnlo = fastnlo-toolkit; # Added 2021-04-24
+  fastnlo_toolkit = fastnlo-toolkit; # Added 2024-01-03
   inherit (luaPackages) fennel; # Added 2022-09-24
   fetchFromGithub = throw "You meant fetchFromGitHub, with a capital H"; # preserve
   findimagedupes = throw "findimagedupes has been removed because the perl bindings are no longer compatible"; # Added 2023-07-10
diff --git a/pkgs/top-level/all-packages.nix b/pkgs/top-level/all-packages.nix
index 19754fc6b4ef..25facdf81463 100644
--- a/pkgs/top-level/all-packages.nix
+++ b/pkgs/top-level/all-packages.nix
@@ -40006,7 +40006,7 @@ with pkgs;
 
   fastjet-contrib = callPackage ../development/libraries/physics/fastjet-contrib { };
 
-  fastnlo_toolkit = callPackage ../development/libraries/physics/fastnlo_toolkit { };
+  fastnlo-toolkit = callPackage ../development/libraries/physics/fastnlo-toolkit { };
 
   geant4 = libsForQt5.callPackage ../development/libraries/physics/geant4 { };
 
diff --git a/pkgs/top-level/python-aliases.nix b/pkgs/top-level/python-aliases.nix
index e816cfe2a9a7..a6ba453d6fa4 100644
--- a/pkgs/top-level/python-aliases.nix
+++ b/pkgs/top-level/python-aliases.nix
@@ -140,6 +140,7 @@ mapAliases ({
   face_recognition_models = face-recognition-models; # added 2022-10-15
   factory_boy = factory-boy; # added 2023-10-08
   fake_factory = throw "fake_factory has been removed because it is unused and deprecated by upstream since 2016."; # added 2022-05-30
+  fastnlo_toolkit = fastnlo-toolkit; # added 2024-01-03
   faulthandler = throw "faulthandler is built into ${python.executable}"; # added 2021-07-12
   inherit (super.pkgs) fetchPypi; # added 2023-05-25
   filemagic = throw "inactive since 2014, so use python-magic instead"; # added 2022-11-19
diff --git a/pkgs/top-level/python-packages.nix b/pkgs/top-level/python-packages.nix
index 27cf855a52d5..9168a532f653 100644
--- a/pkgs/top-level/python-packages.nix
+++ b/pkgs/top-level/python-packages.nix
@@ -3915,7 +3915,7 @@ self: super: with self; {
 
   fastjsonschema = callPackage ../development/python-modules/fastjsonschema { };
 
-  fastnlo_toolkit = toPythonModule (pkgs.fastnlo_toolkit.override {
+  fastnlo-toolkit = toPythonModule (pkgs.fastnlo-toolkit.override {
     withPython = true;
     inherit (self) python;
   });