about summary refs log tree commit diff
path: root/pkgs/top-level
diff options
context:
space:
mode:
authorCillian de Róiste <goibhniu@fsfe.org>2014-01-28 12:13:28 +0100
committerCillian de Róiste <goibhniu@fsfe.org>2014-01-28 12:13:41 +0100
commit197de444dfaad1137b45b7ad61cd36e16a5c0852 (patch)
treeaa365bd0b9a06d12b161128bb76cb3c296bb035b /pkgs/top-level
parente5995e0703de588af9d71e636eea7ddb1c695af0 (diff)
downloadnixlib-197de444dfaad1137b45b7ad61cd36e16a5c0852.tar
nixlib-197de444dfaad1137b45b7ad61cd36e16a5c0852.tar.gz
nixlib-197de444dfaad1137b45b7ad61cd36e16a5c0852.tar.bz2
nixlib-197de444dfaad1137b45b7ad61cd36e16a5c0852.tar.lz
nixlib-197de444dfaad1137b45b7ad61cd36e16a5c0852.tar.xz
nixlib-197de444dfaad1137b45b7ad61cd36e16a5c0852.tar.zst
nixlib-197de444dfaad1137b45b7ad61cd36e16a5c0852.zip
ipython: disable support for qtconsole, pylabQt and pylab on Darwin
Qt and CUPS are not supported on Darwin and are dependencies.

Note: this makes ipython the same as ipythonLight on Darwin, but
ipython is used as an input for other packages (ipdb and ipdplugin)
and it is reasonable to assume that users on other platforms may
choose ipythonLight.
Diffstat (limited to 'pkgs/top-level')
-rw-r--r--pkgs/top-level/python-packages.nix3
1 files changed, 3 insertions, 0 deletions
diff --git a/pkgs/top-level/python-packages.nix b/pkgs/top-level/python-packages.nix
index 5718572399f8..62c37e5d30bd 100644
--- a/pkgs/top-level/python-packages.nix
+++ b/pkgs/top-level/python-packages.nix
@@ -65,6 +65,9 @@ pythonPackages = modules // import ./python-packages-generated.nix {
   ipython = import ../shells/ipython {
     inherit (pkgs) stdenv fetchurl sip pyqt4;
     inherit buildPythonPackage pythonPackages;
+    qtconsoleSupport = !pkgs.stdenv.isDarwin; # qt is not supported on darwin
+    pylabQtSupport = !pkgs.stdenv.isDarwin;
+    pylabSupport = !pkgs.stdenv.isDarwin; # cups is not supported on darwin
   };
 
   ipythonLight = lowPrio (import ../shells/ipython {