about summary refs log tree commit diff
path: root/pkgs/top-level
diff options
context:
space:
mode:
authorThéophane Hufschmitt <theophane.hufschmitt@polytechnique.org>2016-04-21 13:56:20 +0200
committerThéophane Hufschmitt <theophane.hufschmitt@polytechnique.org>2016-04-25 13:18:58 +0200
commit130078a73abb2bf334ba11027ac20c75d43f662e (patch)
tree31fdff2a00141b5e0585ac193cc9c21354bc8dae /pkgs/top-level
parent31d76ae1b1f8c3ef71e84dd002f0c9396edfa6ca (diff)
downloadnixlib-130078a73abb2bf334ba11027ac20c75d43f662e.tar
nixlib-130078a73abb2bf334ba11027ac20c75d43f662e.tar.gz
nixlib-130078a73abb2bf334ba11027ac20c75d43f662e.tar.bz2
nixlib-130078a73abb2bf334ba11027ac20c75d43f662e.tar.lz
nixlib-130078a73abb2bf334ba11027ac20c75d43f662e.tar.xz
nixlib-130078a73abb2bf334ba11027ac20c75d43f662e.tar.zst
nixlib-130078a73abb2bf334ba11027ac20c75d43f662e.zip
pythonPackages.repeated_test : init at 0.1a3
Diffstat (limited to 'pkgs/top-level')
-rw-r--r--pkgs/top-level/python-packages.nix23
1 files changed, 23 insertions, 0 deletions
diff --git a/pkgs/top-level/python-packages.nix b/pkgs/top-level/python-packages.nix
index 1232f7a58fd2..56a42db00caf 100644
--- a/pkgs/top-level/python-packages.nix
+++ b/pkgs/top-level/python-packages.nix
@@ -26588,4 +26588,27 @@ in modules // {
       maintainers = with maintainers; [];
     };
   };
+
+  repeated_test = buildPythonPackage rec {
+    name = "repeated_test-${version}";
+    version = "0.1a3";
+
+    src = pkgs.fetchurl {
+      url = "https://pypi.python.org/packages/source/r/repeated-test/${name}.tar.gz";
+      sha256 = "062syp7kl2g0x6qx3z8zb5sdycpi7qcpxp9iml2v8dqzqnij9bpg";
+    };
+
+    buildInputs = with self; [
+      unittest2
+    ];
+    propagatedBuildInputs = with self; [
+      six
+    ];
+
+    meta = {
+      description = "A quick unittest-compatible framework for repeating a test function over many fixtures";
+      homepage = "https://github.com/epsy/repeated_test";
+      license = licenses.mit;
+    };
+  };
 }