about summary refs log tree commit diff
path: root/pkgs/top-level
diff options
context:
space:
mode:
authorMoritz Ulrich <moritz@tarn-vedra.de>2016-04-27 10:04:41 +0200
committerMoritz Ulrich <moritz@tarn-vedra.de>2016-04-27 10:04:41 +0200
commit12554997a79a0289866f821d55b78d437df3aa91 (patch)
treee75336970477b1468d772c675914a4014c5fe05e /pkgs/top-level
parent6e24c9974fbacbeb1c3d1327807ca4b0bfe861f2 (diff)
downloadnixlib-12554997a79a0289866f821d55b78d437df3aa91.tar
nixlib-12554997a79a0289866f821d55b78d437df3aa91.tar.gz
nixlib-12554997a79a0289866f821d55b78d437df3aa91.tar.bz2
nixlib-12554997a79a0289866f821d55b78d437df3aa91.tar.lz
nixlib-12554997a79a0289866f821d55b78d437df3aa91.tar.xz
nixlib-12554997a79a0289866f821d55b78d437df3aa91.tar.zst
nixlib-12554997a79a0289866f821d55b78d437df3aa91.zip
rustc+cargo: Mark -unstable as lowPrio.
Diffstat (limited to 'pkgs/top-level')
-rw-r--r--pkgs/top-level/all-packages.nix8
1 files changed, 4 insertions, 4 deletions
diff --git a/pkgs/top-level/all-packages.nix b/pkgs/top-level/all-packages.nix
index 36239d294319..4008384dde47 100644
--- a/pkgs/top-level/all-packages.nix
+++ b/pkgs/top-level/all-packages.nix
@@ -5097,13 +5097,13 @@ in
 
   rtags = callPackage ../development/tools/rtags/default.nix {};
 
-  rustcMaster = callPackage ../development/compilers/rustc/head.nix {};
+  rustcMaster = lowPrio (callPackage ../development/compilers/rustc/head.nix {});
   rustc = callPackage ../development/compilers/rustc {};
 
   rustPlatform = rustStable;
 
   rustStable = recurseIntoAttrs (makeRustPlatform cargo rustStable);
-  rustUnstable = recurseIntoAttrs (makeRustPlatform cargoUnstable rustUnstable);
+  rustUnstable = lowPrio (recurseIntoAttrs (makeRustPlatform cargoUnstable rustUnstable));
 
   # rust platform to build cargo itself (with cargoSnapshot)
   rustCargoPlatform = makeRustPlatform (cargoSnapshot rustc) rustCargoPlatform;
@@ -5783,9 +5783,9 @@ in
     rustPlatform = rustCargoPlatform;
   };
 
-  cargoUnstable = callPackage ../development/tools/build-managers/cargo/head.nix {
+  cargoUnstable = lowPrio (callPackage ../development/tools/build-managers/cargo/head.nix {
     rustPlatform = rustUnstableCargoPlatform;
-  };
+  });
 
   cargoSnapshot = rustc:
     callPackage ../development/tools/build-managers/cargo/snapshot.nix {