about summary refs log tree commit diff
path: root/pkgs/top-level
diff options
context:
space:
mode:
authorPhilip Taron <philip.taron@gmail.com>2024-03-05 17:59:07 -0800
committerPhilip Taron <philip.taron@gmail.com>2024-03-08 14:44:57 -0800
commit11bf7021af1224bdde92453ff4490aa9d2aa5f28 (patch)
tree5a2e0935a326799b0918cf0c23681a194dd276bd /pkgs/top-level
parenta7cdb7f2b12c6f14facdef2cd9a10efd1f407918 (diff)
downloadnixlib-11bf7021af1224bdde92453ff4490aa9d2aa5f28.tar
nixlib-11bf7021af1224bdde92453ff4490aa9d2aa5f28.tar.gz
nixlib-11bf7021af1224bdde92453ff4490aa9d2aa5f28.tar.bz2
nixlib-11bf7021af1224bdde92453ff4490aa9d2aa5f28.tar.lz
nixlib-11bf7021af1224bdde92453ff4490aa9d2aa5f28.tar.xz
nixlib-11bf7021af1224bdde92453ff4490aa9d2aa5f28.tar.zst
nixlib-11bf7021af1224bdde92453ff4490aa9d2aa5f28.zip
Avoid `with lib;` at the top level in pkgs/top-level/unixtools.nix
Diffstat (limited to 'pkgs/top-level')
-rw-r--r--pkgs/top-level/unixtools.nix13
1 files changed, 9 insertions, 4 deletions
diff --git a/pkgs/top-level/unixtools.nix b/pkgs/top-level/unixtools.nix
index bcbbd6799d88..454c4802dc91 100644
--- a/pkgs/top-level/unixtools.nix
+++ b/pkgs/top-level/unixtools.nix
@@ -10,9 +10,14 @@
 # instance, if your program needs to use "ps", just list it as a build
 # input, not "procps" which requires Linux.
 
-with lib;
-
 let
+  inherit (lib)
+    getBin
+    getOutput
+    mapAttrs
+    platforms
+    ;
+
   version = "1003.1-2008";
 
   singleBinary = cmd: providers: let
@@ -23,7 +28,7 @@ let
       meta = {
         mainProgram = cmd;
         priority = 10;
-        platforms = lib.platforms.${stdenv.hostPlatform.parsed.kernel.name} or lib.platforms.all;
+        platforms = platforms.${stdenv.hostPlatform.parsed.kernel.name} or platforms.all;
       };
       passthru = { inherit provider; };
       preferLocalBuild = true;
@@ -187,7 +192,7 @@ let
 
   # Compatibility derivations
   # Provided for old usage of these commands.
-  compat = with bins; lib.mapAttrs makeCompat {
+  compat = with bins; mapAttrs makeCompat {
     procps = [ ps sysctl top watch ];
     util-linux = [ fsck fdisk getopt hexdump mount
                   script umount whereis write col column ];