about summary refs log tree commit diff
path: root/pkgs/top-level
diff options
context:
space:
mode:
authorElis Hirwing <elis@hirwing.se>2020-04-19 20:51:57 +0200
committerElis Hirwing <elis@hirwing.se>2020-04-29 20:15:47 +0200
commit0b04a477a1c562afaf415463f5f9611c456b8721 (patch)
tree0cb2b468c7d35c2e3cfc5dba547be48f8a352702 /pkgs/top-level
parented12b30bee39d5b8748ca5a94180ff1a181d6247 (diff)
downloadnixlib-0b04a477a1c562afaf415463f5f9611c456b8721.tar
nixlib-0b04a477a1c562afaf415463f5f9611c456b8721.tar.gz
nixlib-0b04a477a1c562afaf415463f5f9611c456b8721.tar.bz2
nixlib-0b04a477a1c562afaf415463f5f9611c456b8721.tar.lz
nixlib-0b04a477a1c562afaf415463f5f9611c456b8721.tar.xz
nixlib-0b04a477a1c562afaf415463f5f9611c456b8721.tar.zst
nixlib-0b04a477a1c562afaf415463f5f9611c456b8721.zip
php.packages: Add php maintainer team to all packages
Diffstat (limited to 'pkgs/top-level')
-rw-r--r--pkgs/top-level/php-packages.nix29
1 files changed, 15 insertions, 14 deletions
diff --git a/pkgs/top-level/php-packages.nix b/pkgs/top-level/php-packages.nix
index be9c7a5ad13e..a15ca794cace 100644
--- a/pkgs/top-level/php-packages.nix
+++ b/pkgs/top-level/php-packages.nix
@@ -52,7 +52,7 @@ in
         description = "An application for building and managing Phars";
         license = licenses.mit;
         homepage = "https://box-project.github.io/box2/";
-        maintainers = with maintainers; [ jtojnar ];
+        maintainers = with maintainers; [ jtojnar ] ++ teams.php.members;
       };
     };
 
@@ -81,7 +81,7 @@ in
         description = "Dependency Manager for PHP";
         license = licenses.mit;
         homepage = "https://getcomposer.org/";
-        maintainers = with maintainers; [ globin offline ];
+        maintainers = with maintainers; [ offline ] ++ teams.php.members;
       };
     };
 
@@ -108,7 +108,7 @@ in
         description = "A tool to automatically fix PHP coding standards issues";
         license = licenses.mit;
         homepage = "http://cs.sensiolabs.org/";
-        maintainers = with maintainers; [ jtojnar ];
+        maintainers = with maintainers; [ jtojnar ] ++ teams.php.members;
       };
     };
 
@@ -145,7 +145,7 @@ in
         description = "This tool check syntax of PHP files faster than serial check with fancier output";
         license = licenses.bsd2;
         homepage = "https://github.com/JakubOnderka/PHP-Parallel-Lint";
-        maintainers = with maintainers; [ jtojnar ];
+        maintainers = with maintainers; [ jtojnar ] ++ teams.php.members;
       };
     };
 
@@ -172,7 +172,7 @@ in
         description = "PHP coding standard beautifier and fixer";
         license = licenses.bsd3;
         homepage = "https://squizlabs.github.io/PHP_CodeSniffer/";
-        maintainers = with maintainers; [ cmcdragonkai etu ];
+        maintainers = with maintainers; [ cmcdragonkai ] ++ teams.php.members;
       };
     };
 
@@ -199,7 +199,7 @@ in
         description = "PHP coding standard tool";
         license = licenses.bsd3;
         homepage = "https://squizlabs.github.io/PHP_CodeSniffer/";
-        maintainers = with maintainers; [ javaguirre etu ];
+        maintainers = with maintainers; [ javaguirre ] ++ teams.php.members;
       };
     };
 
@@ -225,15 +225,15 @@ in
       meta = with pkgs.lib; {
         description = "PHP Static Analysis Tool";
         longDescription = ''
-        PHPStan focuses on finding errors in your code without actually running
-        it. It catches whole classes of bugs even before you write tests for the
-        code. It moves PHP closer to compiled languages in the sense that the
-        correctness of each line of the code can be checked before you run the
-        actual line.
-      '';
+          PHPStan focuses on finding errors in your code without actually
+          running it. It catches whole classes of bugs even before you write
+          tests for the code. It moves PHP closer to compiled languages in the
+          sense that the correctness of each line of the code can be checked
+          before you run the actual line.
+        '';
         license = licenses.mit;
         homepage = "https://github.com/phpstan/phpstan";
-        maintainers = with maintainers; [ etu ];
+        maintainers = teams.php.members;
       };
     };
 
@@ -260,6 +260,7 @@ in
         description = "A static analysis tool for finding errors in PHP applications";
         license = licenses.mit;
         homepage = "https://github.com/vimeo/psalm";
+        maintainers = teams.php.members;
       };
     };
 
@@ -286,7 +287,7 @@ in
         description = "PsySH is a runtime developer console, interactive debugger and REPL for PHP.";
         license = licenses.mit;
         homepage = "https://psysh.org/";
-        maintainers = with maintainers; [ caugner ];
+        maintainers = with maintainers; [ caugner ] ++ teams.php.members;
       };
     };
   };