about summary refs log tree commit diff
path: root/pkgs/top-level
diff options
context:
space:
mode:
authorMichael Raskin <7c6f434c@mail.ru>2008-06-12 15:59:59 +0000
committerMichael Raskin <7c6f434c@mail.ru>2008-06-12 15:59:59 +0000
commit0784550c35e0b0e53b0b5ae6957d708102bb17a7 (patch)
treeec0758c1a2a63010ed86e9fad8d9befd69ab4b23 /pkgs/top-level
parent638f4bf12179a025856f29a512252bc04370c736 (diff)
downloadnixlib-0784550c35e0b0e53b0b5ae6957d708102bb17a7.tar
nixlib-0784550c35e0b0e53b0b5ae6957d708102bb17a7.tar.gz
nixlib-0784550c35e0b0e53b0b5ae6957d708102bb17a7.tar.bz2
nixlib-0784550c35e0b0e53b0b5ae6957d708102bb17a7.tar.lz
nixlib-0784550c35e0b0e53b0b5ae6957d708102bb17a7.tar.xz
nixlib-0784550c35e0b0e53b0b5ae6957d708102bb17a7.tar.zst
nixlib-0784550c35e0b0e53b0b5ae6957d708102bb17a7.zip
Added ViewMTN and dependency; currently ViewMTN has to be manually symlinked in corresponding directory.
svn path=/nixpkgs/trunk/; revision=12060
Diffstat (limited to 'pkgs/top-level')
-rw-r--r--pkgs/top-level/all-packages.nix25
-rw-r--r--pkgs/top-level/builder-defs.nix13
2 files changed, 35 insertions, 3 deletions
diff --git a/pkgs/top-level/all-packages.nix b/pkgs/top-level/all-packages.nix
index 2380eca4bddc..50b0c5b31fb4 100644
--- a/pkgs/top-level/all-packages.nix
+++ b/pkgs/top-level/all-packages.nix
@@ -503,7 +503,8 @@ let pkgs = rec {
   };
 
   cheetahTemplate = builderDefsPackage (selectVersion ../tools/text/cheetah-template "2.0.1") {
-    inherit python makeWrapper;
+    inherit makeWrapper;
+    python = python25;
   } null;
 
   chkrootkit = import ../tools/security/chkrootkit {
@@ -739,6 +740,10 @@ let pkgs = rec {
     inherit fetchurl stdenv ocaml;
   };
 
+  highlight = builderDefsPackage (selectVersion ../tools/text/highlight "2.6.10") {
+    inherit getopt;
+  } null;
+
   /*
   hyppocampusFun = lib.sumArgs ( selectVersion ../tools/misc/hyppocampus "0.3rc1") {
     inherit builderDefs stdenv fetchurl libdbi libdbiDrivers fuse
@@ -1653,6 +1658,13 @@ let pkgs = rec {
     inherit (gnome) gtk libgnomecanvas glib;
   } null;
 
+  viewMtn = builderDefsPackage (selectVersion ../applications/version-management/viewmtn "0.10")
+  {
+    inherit monotone flup cheetahTemplate highlight ctags 
+      makeWrapper graphviz which;
+    python = python25;
+  } null;
+
   nasm = import ../development/compilers/nasm {
     inherit fetchurl stdenv;
   };
@@ -4202,6 +4214,13 @@ let pkgs = rec {
     inherit fetchurl stdenv python db4;
   };
 
+  flup = builderDefsPackage (selectVersion ../development/python-modules/flup "r2311") 
+  (let python=python25; in 
+  {
+    inherit python;
+    setuptools = setuptools.meta.function {inherit python;} null;
+  }) null;
+
   pil = import ../development/python-modules/pil {
     inherit fetchurl stdenv python zlib libtiff libjpeg freetype;
   };
@@ -4253,6 +4272,10 @@ let pkgs = rec {
     inherit fetchurl stdenv python makeWrapper;
   };
 
+  setuptools = builderDefsPackage (selectVersion ../development/python-modules/setuptools "0.6c8") {
+    python = python25;
+  } null;
+
   wxPython = wxPython26;
 
   wxPython26 = import ../development/python-modules/wxPython/2.6.nix {
diff --git a/pkgs/top-level/builder-defs.nix b/pkgs/top-level/builder-defs.nix
index 837ca0c0f8b7..112f6b5c2ffe 100644
--- a/pkgs/top-level/builder-defs.nix
+++ b/pkgs/top-level/builder-defs.nix
@@ -307,10 +307,15 @@ args: with args; with stringsWithDeps; with lib;
 
 	wrapBinContentsPython = (makeManyWrappers 
 	  ''$out/bin/*'' 
-	  (''--prefix PYTHONPATH : $(toPythonPath $out)'' +
-	  ''''${PYTHONPATH:+ --prefix PYTHONPATH : $PYTHONPATH}'')
+	  pythonWrapperArguments
 	);
 
+	pythonWrapperArguments = 
+	  (''--prefix PYTHONPATH : $(toPythonPath $out)'' +
+	  ''''${PYTHONPATH:+ --prefix PYTHONPATH : $PYTHONPATH}'');
+
+	preservePathWrapperArguments = ''''${PATH:+ --prefix PATH : $PATH }'';
+
 	doPropagate = FullDepEntry ("
 		ensureDir \$out/nix-support
 		echo '${toString (getAttr ["propagatedBuildInputs"] [] args)}' >\$out/nix-support/propagated-build-inputs
@@ -507,4 +512,8 @@ args: with args; with stringsWithDeps; with lib;
      patchShebangFun;
    '') ["minInit"];
 
+   createPythonInstallationTarget = FullDepEntry (''
+     ensureDir $(toPythonPath $out)
+     export PYTHONPATH=$PYTHONPATH''${PYTHONPATH:+:}$(toPythonPath $out)
+   '') ["minInit" "addInputs" "defEnsureDir"];
 }) // args