about summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorworldofpeace <worldofpeace@protonmail.ch>2019-09-17 13:04:33 -0400
committerGitHub <noreply@github.com>2019-09-17 13:04:33 -0400
commitfef262cd925b6905d879bd64fdafefe382586f4c (patch)
tree5ee69376380362e6b9a2d6b831e71535de1c6246 /pkgs/tools
parent7d16370c63a57e133a906d27e7a10e9b2a238149 (diff)
parent96b22bb697b722b9c3389abd0b304813e8a6b0d9 (diff)
downloadnixlib-fef262cd925b6905d879bd64fdafefe382586f4c.tar
nixlib-fef262cd925b6905d879bd64fdafefe382586f4c.tar.gz
nixlib-fef262cd925b6905d879bd64fdafefe382586f4c.tar.bz2
nixlib-fef262cd925b6905d879bd64fdafefe382586f4c.tar.lz
nixlib-fef262cd925b6905d879bd64fdafefe382586f4c.tar.xz
nixlib-fef262cd925b6905d879bd64fdafefe382586f4c.tar.zst
nixlib-fef262cd925b6905d879bd64fdafefe382586f4c.zip
Merge pull request #68893 from sikmir/qt5ct
qt5ct: 0.39 -> 0.41
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/misc/qt5ct/default.nix9
-rw-r--r--pkgs/tools/misc/qt5ct/wayland.patch22
2 files changed, 2 insertions, 29 deletions
diff --git a/pkgs/tools/misc/qt5ct/default.nix b/pkgs/tools/misc/qt5ct/default.nix
index fbb56b98be77..952268b26f01 100644
--- a/pkgs/tools/misc/qt5ct/default.nix
+++ b/pkgs/tools/misc/qt5ct/default.nix
@@ -4,22 +4,17 @@ let inherit (lib) getDev; in
 
 mkDerivation rec {
   pname = "qt5ct";
-  version = "0.39";
+  version = "0.41";
 
   src = fetchurl {
     url = "mirror://sourceforge/${pname}/${pname}-${version}.tar.bz2";
-    sha256 = "069y6c17gfics8rz3rdsn2x2hb39m4qka08ygwpxa8gqppffqs9p";
+    sha256 = "1p2p6116wg5bc0hcbi2sygwlgk0g9idxpci0qdh3p4lb1plk0h7j";
   };
 
   nativeBuildInputs = [ qmake qttools ];
 
   buildInputs = [ qtbase ];
 
-  # Wayland needs to know the desktop file name in order to show the app name and icon.
-  # Patch has been upstreamed and can be removed in the future.
-  # See: https://sourceforge.net/p/qt5ct/code/549/
-  patches = [ ./wayland.patch ];
-
   qmakeFlags = [
     "LRELEASE_EXECUTABLE=${getDev qttools}/bin/lrelease"
   ];
diff --git a/pkgs/tools/misc/qt5ct/wayland.patch b/pkgs/tools/misc/qt5ct/wayland.patch
deleted file mode 100644
index fe186cfa4692..000000000000
--- a/pkgs/tools/misc/qt5ct/wayland.patch
+++ /dev/null
@@ -1,22 +0,0 @@
---- a/src/qt5ct/main.cpp
-+++ b/src/qt5ct/main.cpp
-@@ -29,14 +29,18 @@
- #include <QApplication>
- #include <QLibraryInfo>
- #include <QLocale>
--#include "qt5ct.h"
-+#include <QtGlobal>
- #include <QTranslator>
- #include <QtDebug>
-+#include "qt5ct.h"
- #include "mainwindow.h"
- 
- int main(int argc, char **argv)
- {
-     QApplication app(argc, argv);
-+#if (QT_VERSION >= QT_VERSION_CHECK(5, 7, 0))
-+    QGuiApplication::setDesktopFileName("qt5ct.desktop");
-+#endif
-     QTranslator translator;
-     QString locale = Qt5CT::systemLanguageID();
-     translator.load(QString(":/qt5ct_") + locale);
\ No newline at end of file