about summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorShea Levy <shea@shealevy.com>2014-03-22 20:56:00 -0400
committerShea Levy <shea@shealevy.com>2014-03-22 20:56:00 -0400
commitfc0ea57efc7a6f601b0d0f07141d79174852860e (patch)
treee84ef6ad5129e061c6faa8f2a0269618e7d4aaed /pkgs/tools
parent2c9f176b94624adc0ac7536c3e2bf05708826e3e (diff)
parent3f2b74bf088cedc20d54314b32c6a0699adb0c40 (diff)
downloadnixlib-fc0ea57efc7a6f601b0d0f07141d79174852860e.tar
nixlib-fc0ea57efc7a6f601b0d0f07141d79174852860e.tar.gz
nixlib-fc0ea57efc7a6f601b0d0f07141d79174852860e.tar.bz2
nixlib-fc0ea57efc7a6f601b0d0f07141d79174852860e.tar.lz
nixlib-fc0ea57efc7a6f601b0d0f07141d79174852860e.tar.xz
nixlib-fc0ea57efc7a6f601b0d0f07141d79174852860e.tar.zst
nixlib-fc0ea57efc7a6f601b0d0f07141d79174852860e.zip
Merge branch 'misc-gvolicon' of git://github.com/bennofs/nixpkgs
new expression: gvolicon
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/audio/gvolicon/default.nix27
1 files changed, 27 insertions, 0 deletions
diff --git a/pkgs/tools/audio/gvolicon/default.nix b/pkgs/tools/audio/gvolicon/default.nix
new file mode 100644
index 000000000000..311e420c6a31
--- /dev/null
+++ b/pkgs/tools/audio/gvolicon/default.nix
@@ -0,0 +1,27 @@
+{ stdenv, makeWrapper, alsaLib, pkgconfig, fetchgit, gnome3, hicolor_icon_theme, gdk_pixbuf, librsvg }:
+
+stdenv.mkDerivation {
+  name = "gvolicon";
+  src = fetchgit {
+    url = "https://github.com/Unia/gvolicon";
+    rev = "26343415de836e0b05aa0b480c0c69cc2ed9e419";
+    sha256 = "68858840a45b5f74803e85116c6219f805d6d944c00354662889549910856cdd";
+  };
+
+  buildInputs = [ pkgconfig makeWrapper alsaLib gnome3.gtk ];
+  propagatedBuildInputs = [ gnome3.gnome_icon_theme gnome3.gnome_icon_theme_symbolic hicolor_icon_theme gdk_pixbuf librsvg ];
+  installPhase = ''
+    make install PREFIX=$out
+    wrapProgram "$out/bin/gvolicon" \
+      --set GDK_PIXBUF_MODULE_FILE "$GDK_PIXBUF_MODULE_FILE" \
+      --prefix XDG_DATA_DIRS : "${gnome3.gtk}/share:${gnome3.gnome_themes_standard}/share:${gnome3.gsettings_desktop_schemas}/share:$out/share:$out/share/gvolicon:$XDG_ICON_DIRS"
+    '';
+
+  meta = {
+    description = "A simple and lightweight volume icon that sits in your system tray.";
+    homepage = "https://github.com/Unia/gvolicon";
+    platforms = stdenv.lib.platforms.linux;
+    license = stdenv.lib.licenses.gpl3Plus;
+    maintainer = stdenv.lib.maintainers.bennofs;
+  };
+}
\ No newline at end of file