about summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorFabian Möller <fabianm88@gmail.com>2019-09-17 14:24:04 +0200
committerFabian Möller <fabianm88@gmail.com>2019-09-17 14:24:04 +0200
commitf8860eb6701d316ae6497b72195bc1c5b2a61666 (patch)
tree458dc5572eec6e47741796a81d6368f67a15f6e4 /pkgs/tools
parent83686eb1fbab85a8631e28ae9c2517deb2380a80 (diff)
downloadnixlib-f8860eb6701d316ae6497b72195bc1c5b2a61666.tar
nixlib-f8860eb6701d316ae6497b72195bc1c5b2a61666.tar.gz
nixlib-f8860eb6701d316ae6497b72195bc1c5b2a61666.tar.bz2
nixlib-f8860eb6701d316ae6497b72195bc1c5b2a61666.tar.lz
nixlib-f8860eb6701d316ae6497b72195bc1c5b2a61666.tar.xz
nixlib-f8860eb6701d316ae6497b72195bc1c5b2a61666.tar.zst
nixlib-f8860eb6701d316ae6497b72195bc1c5b2a61666.zip
boringtun: fix darwin build
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/networking/boringtun/default.nix4
1 files changed, 3 insertions, 1 deletions
diff --git a/pkgs/tools/networking/boringtun/default.nix b/pkgs/tools/networking/boringtun/default.nix
index 068d51229cb1..05e9ba1282eb 100644
--- a/pkgs/tools/networking/boringtun/default.nix
+++ b/pkgs/tools/networking/boringtun/default.nix
@@ -1,4 +1,4 @@
-{ stdenv, fetchFromGitHub, rustPlatform }:
+{ stdenv, fetchFromGitHub, rustPlatform, darwin }:
 
 rustPlatform.buildRustPackage rec {
   pname = "boringtun";
@@ -21,6 +21,8 @@ rustPlatform.buildRustPackage rec {
   # we append a new line to the end of file.
   preConfigure = "echo '' >> .cargo/config";
 
+  buildInputs = stdenv.lib.optional stdenv.isDarwin darwin.apple_sdk.frameworks.Security;
+
   # Testing this project requires sudo, Docker and network access, etc.
   doCheck = false;