about summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorMario Rodas <marsam@users.noreply.github.com>2024-02-04 04:20:00 +0000
committerMario Rodas <marsam@users.noreply.github.com>2024-02-04 04:20:00 +0000
commitf56f725f8c15710680b2b09e07289724b2580849 (patch)
tree0710a1c1ac32845521c5fe90be5c70bac8d0e754 /pkgs/tools
parentb06fade334e23657500280dbc69893250f598691 (diff)
downloadnixlib-f56f725f8c15710680b2b09e07289724b2580849.tar
nixlib-f56f725f8c15710680b2b09e07289724b2580849.tar.gz
nixlib-f56f725f8c15710680b2b09e07289724b2580849.tar.bz2
nixlib-f56f725f8c15710680b2b09e07289724b2580849.tar.lz
nixlib-f56f725f8c15710680b2b09e07289724b2580849.tar.xz
nixlib-f56f725f8c15710680b2b09e07289724b2580849.tar.zst
nixlib-f56f725f8c15710680b2b09e07289724b2580849.zip
rage: 0.9.2 -> 0.10.0
Diff: https://github.com/str4d/rage/compare/v0.9.2...v0.10.0

Changelog: https://github.com/str4d/rage/blob/v0.10.0/rage/CHANGELOG.md
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/security/rage/default.nix20
1 files changed, 9 insertions, 11 deletions
diff --git a/pkgs/tools/security/rage/default.nix b/pkgs/tools/security/rage/default.nix
index 44b67e96a1e0..edd9f335eded 100644
--- a/pkgs/tools/security/rage/default.nix
+++ b/pkgs/tools/security/rage/default.nix
@@ -8,16 +8,16 @@
 
 rustPlatform.buildRustPackage rec {
   pname = "rage";
-  version = "0.9.2";
+  version = "0.10.0";
 
   src = fetchFromGitHub {
     owner = "str4d";
     repo = pname;
     rev = "v${version}";
-    hash = "sha256-hFuuwmwe0ti4Y8mSJyNqUIhZjFC6qtv6W5cwtNjPUFQ=";
+    hash = "sha256-7PfNDFDuvQ9T3BeA15FuY1jAprGLsyglWXcNrZvtPAE=";
   };
 
-  cargoHash = "sha256-1gtLWU6uiWzUfYy9y3pb2vcnUC3H+Mf9rglmqNd989M=";
+  cargoHash = "sha256-5aLT0JfeFj0fZP/1sHXulCQtoquHYriapMdPtN+fxko=";
 
   nativeBuildInputs = [
     installShellFiles
@@ -30,20 +30,18 @@ rustPlatform.buildRustPackage rec {
   # cargo test has an x86-only dependency
   doCheck = stdenv.hostPlatform.isx86;
 
-  postBuild = ''
-    cargo run --example generate-docs
-    cargo run --example generate-completions
-  '';
-
   postInstall = ''
-    installManPage target/manpages/*
-    installShellCompletion target/completions/*.{bash,fish,zsh}
+    installManPage target/*/release/manpages/man1/*
+    installShellCompletion \
+      --bash target/*/release/completions/*.bash \
+      --fish target/*/release/completions/*.fish \
+      --zsh target/*/release/completions/_*
   '';
 
   meta = with lib; {
     description = "A simple, secure and modern encryption tool with small explicit keys, no config options, and UNIX-style composability";
     homepage = "https://github.com/str4d/rage";
-    changelog = "https://github.com/str4d/rage/raw/v${version}/rage/CHANGELOG.md";
+    changelog = "https://github.com/str4d/rage/blob/v${version}/rage/CHANGELOG.md";
     license = with licenses; [ asl20 mit ]; # either at your option
     maintainers = with maintainers; [ marsam ryantm ];
     mainProgram = "rage";