about summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorSarah Brofeldt <sbrofeldt@gmail.com>2019-07-18 18:52:21 +0200
committerGitHub <noreply@github.com>2019-07-18 18:52:21 +0200
commitf4ed4b8e4d3ccc188c435a8bccc198415fee81f3 (patch)
tree79b3f1f1c0becf1b83cd37cc0c814989b928ee92 /pkgs/tools
parent1285026f68b8ef2f4906cd9669fe61398f678530 (diff)
parent89fa31e4abeba7e17e072af52565aa384e612af4 (diff)
downloadnixlib-f4ed4b8e4d3ccc188c435a8bccc198415fee81f3.tar
nixlib-f4ed4b8e4d3ccc188c435a8bccc198415fee81f3.tar.gz
nixlib-f4ed4b8e4d3ccc188c435a8bccc198415fee81f3.tar.bz2
nixlib-f4ed4b8e4d3ccc188c435a8bccc198415fee81f3.tar.lz
nixlib-f4ed4b8e4d3ccc188c435a8bccc198415fee81f3.tar.xz
nixlib-f4ed4b8e4d3ccc188c435a8bccc198415fee81f3.tar.zst
nixlib-f4ed4b8e4d3ccc188c435a8bccc198415fee81f3.zip
Merge pull request #64777 from jonringer/ytcc-enable-tests
ytcc: enable tests
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/networking/ytcc/default.nix14
1 files changed, 12 insertions, 2 deletions
diff --git a/pkgs/tools/networking/ytcc/default.nix b/pkgs/tools/networking/ytcc/default.nix
index 137a9216df00..d489d84d1cc6 100644
--- a/pkgs/tools/networking/ytcc/default.nix
+++ b/pkgs/tools/networking/ytcc/default.nix
@@ -11,10 +11,20 @@ python3Packages.buildPythonApplication rec {
     sha256 = "080p145j5pg8db88kb0y3x1pfc3v4aj3w68pdihlmi68dhjdr7i7";
   };
 
-  doCheck = false; # try to access /homeless-shelter
+  nativeBuildInputs = [ gettext ];
+
   propagatedBuildInputs = with python3Packages; [ feedparser lxml sqlalchemy youtube-dl ];
 
-  nativeBuildInputs = [ gettext ];
+  checkInputs = with python3Packages; [ nose pytest ];
+
+  # Disable tests that touch network or shell out to commands
+  checkPhase = ''
+    pytest . -k 'not get_channels \
+                 and not play_video \
+                 and not download_videos \
+                 and not update_all \
+                 and not add_channel_duplicate'
+  '';
 
   meta = {
     description = "Command Line tool to keep track of your favourite YouTube channels without signing up for a Google account";