about summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorWill Dietz <w@wdtz.org>2018-01-14 15:31:19 -0600
committerWill Dietz <w@wdtz.org>2018-02-13 09:44:56 -0600
commitf48258fed25a77011e2cc7d629c7b7c22b1a2547 (patch)
tree2263bde5cea7590cd8c93923dd148263790e1956 /pkgs/tools
parent551f0702c24536e4918c6239de9f32772a6ef165 (diff)
downloadnixlib-f48258fed25a77011e2cc7d629c7b7c22b1a2547.tar
nixlib-f48258fed25a77011e2cc7d629c7b7c22b1a2547.tar.gz
nixlib-f48258fed25a77011e2cc7d629c7b7c22b1a2547.tar.bz2
nixlib-f48258fed25a77011e2cc7d629c7b7c22b1a2547.tar.lz
nixlib-f48258fed25a77011e2cc7d629c7b7c22b1a2547.tar.xz
nixlib-f48258fed25a77011e2cc7d629c7b7c22b1a2547.tar.zst
nixlib-f48258fed25a77011e2cc7d629c7b7c22b1a2547.zip
smartmontools: patch from upstream project
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/system/smartmontools/default.nix11
1 files changed, 9 insertions, 2 deletions
diff --git a/pkgs/tools/system/smartmontools/default.nix b/pkgs/tools/system/smartmontools/default.nix
index 5fa55b275fe1..e5b2d54e585d 100644
--- a/pkgs/tools/system/smartmontools/default.nix
+++ b/pkgs/tools/system/smartmontools/default.nix
@@ -1,4 +1,4 @@
-{ stdenv, fetchurl, autoreconfHook
+{ stdenv, fetchurl, fetchpatch, autoreconfHook
 , IOKit ? null , ApplicationServices ? null }:
 
 let
@@ -20,7 +20,14 @@ in stdenv.mkDerivation rec {
     sha256 = "0m1hllbb78rr6cxkbalmz1gqkl0psgq8rrmv4gwcmz34n07kvx2i";
   };
 
-  patches = [ ./smartmontools.patch ];
+  patches = [ ./smartmontools.patch ]
+    # https://www.smartmontools.org/changeset/4603
+    ++ stdenv.lib.optional stdenv.hostPlatform.isMusl (fetchpatch {
+      name = "musl-canonicalize_file_name.patch";
+      url = "https://www.smartmontools.org/changeset/4603?format=diff&new=4603";
+      sha256 = "06s9pcd95snjkrbfrsjby2lln3lnwjd21bgabmvr4p7fx19b75zp";
+      stripLen = 2;
+    });
   postPatch = "cp -v ${driverdb} drivedb.h";
 
   nativeBuildInputs = [ autoreconfHook ];