about summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorBas van Dijk <v.dijk.bas@gmail.com>2018-06-24 13:22:12 +0200
committerBas van Dijk <v.dijk.bas@gmail.com>2018-07-28 00:01:31 +0200
commitebcdb822f8c34aa174e6f688f92699be8f9f57ff (patch)
treef8ca603a99251b4ab4c45abddd4d6c72569f188b /pkgs/tools
parent28e11a0b6ba740aedcc8be27ff8ef334d187bd37 (diff)
downloadnixlib-ebcdb822f8c34aa174e6f688f92699be8f9f57ff.tar
nixlib-ebcdb822f8c34aa174e6f688f92699be8f9f57ff.tar.gz
nixlib-ebcdb822f8c34aa174e6f688f92699be8f9f57ff.tar.bz2
nixlib-ebcdb822f8c34aa174e6f688f92699be8f9f57ff.tar.lz
nixlib-ebcdb822f8c34aa174e6f688f92699be8f9f57ff.tar.xz
nixlib-ebcdb822f8c34aa174e6f688f92699be8f9f57ff.tar.zst
nixlib-ebcdb822f8c34aa174e6f688f92699be8f9f57ff.zip
elk: 6.2.4 -> 6.3.2
* The ELK stack is upgraded to 6.3.2.

* `elasticsearch6`, `logstash6` and `kibana6` now come with X-Pack which is
  a suite of additional features. These are however licensed under the unfree
  "Elastic License".

* Fortunately they also provide OSS versions which are now packaged
  under: `elasticsearch6-oss`, `logstash6-oss` and `kibana6-oss`.
  Note that the naming of the attributes is consistent with upstream.

* The test `nix-build nixos/tests/elk.nix -A ELK-6` will test the OSS
  version by default. You can also run the test on the unfree ELK using:
  `NIXPKGS_ALLOW_UNFREE=1 nix-build nixos/tests/elk.nix -A ELK-6 --arg enableUnfree true`
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/misc/logstash/6.x.nix19
1 files changed, 15 insertions, 4 deletions
diff --git a/pkgs/tools/misc/logstash/6.x.nix b/pkgs/tools/misc/logstash/6.x.nix
index 6aa3fd836965..4f15ba90d39d 100644
--- a/pkgs/tools/misc/logstash/6.x.nix
+++ b/pkgs/tools/misc/logstash/6.x.nix
@@ -1,12 +1,23 @@
-{ stdenv, fetchurl, elk6Version, makeWrapper, jre  }:
+{ elk6Version
+, enableUnfree ? true
+, stdenv
+, fetchurl
+, makeWrapper
+, jre
+}:
+
+with stdenv.lib;
 
 stdenv.mkDerivation rec {
   version = elk6Version;
-  name = "logstash-${version}";
+  name = "logstash-${optionalString (!enableUnfree) "oss-"}${version}";
 
   src = fetchurl {
     url = "https://artifacts.elastic.co/downloads/logstash/${name}.tar.gz";
-    sha256 = "07j3jjg5ik4gjgvcx15qqqas9p1m3815jml82a5r1ip9l6vc4h20";
+    sha256 =
+      if enableUnfree
+      then "0yx9hpiav4d5z1b52x2h5i0iknqs9lmxy8vmz0wkb23mjiz8njdr"
+      else "1ir8pbq706mxr56k5cgc9ajn2jp603zrqj66dimx6xxf2nfamw0w";
   };
 
   dontBuild         = true;
@@ -35,7 +46,7 @@ stdenv.mkDerivation rec {
   meta = with stdenv.lib; {
     description = "Logstash is a data pipeline that helps you process logs and other event data from a variety of systems";
     homepage    = https://www.elastic.co/products/logstash;
-    license     = licenses.asl20;
+    license     = if enableUnfree then licenses.elastic else licenses.asl20;
     platforms   = platforms.unix;
     maintainers = with maintainers; [ wjlroe offline basvandijk ];
   };