about summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorRenaud <c0bw3b@users.noreply.github.com>2018-12-03 11:31:53 +0100
committerGitHub <noreply@github.com>2018-12-03 11:31:53 +0100
commite869896d00d9c7b1485b15e891d21213b4ff97f0 (patch)
treeb7caf4f9802b08261dc2ffac9f28f8413de9678e /pkgs/tools
parent4cde69ad9a162e414c064a0d17c63f88f991d00c (diff)
parentdc21737eddac6494b24bb96e52b2ec42b1f3f8d8 (diff)
downloadnixlib-e869896d00d9c7b1485b15e891d21213b4ff97f0.tar
nixlib-e869896d00d9c7b1485b15e891d21213b4ff97f0.tar.gz
nixlib-e869896d00d9c7b1485b15e891d21213b4ff97f0.tar.bz2
nixlib-e869896d00d9c7b1485b15e891d21213b4ff97f0.tar.lz
nixlib-e869896d00d9c7b1485b15e891d21213b4ff97f0.tar.xz
nixlib-e869896d00d9c7b1485b15e891d21213b4ff97f0.tar.zst
nixlib-e869896d00d9c7b1485b15e891d21213b4ff97f0.zip
Merge pull request #51411 from jfrankenau/update-ntfy
ntfy: 2.6.0 -> 2.7.0
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/misc/ntfy/default.nix37
1 files changed, 37 insertions, 0 deletions
diff --git a/pkgs/tools/misc/ntfy/default.nix b/pkgs/tools/misc/ntfy/default.nix
new file mode 100644
index 000000000000..26517361ae2d
--- /dev/null
+++ b/pkgs/tools/misc/ntfy/default.nix
@@ -0,0 +1,37 @@
+{ stdenv, pythonPackages, fetchFromGitHub }:
+
+pythonPackages.buildPythonApplication rec {
+  pname = "ntfy";
+  version = "2.7.0";
+
+  src = fetchFromGitHub {
+    owner = "dschep";
+    repo = "ntfy";
+    rev = "v${version}";
+    sha256 = "09f02cn4i1l2aksb3azwfb70axqhn7d0d0vl2r6640hqr74nc1cv";
+  };
+
+  checkInputs = with pythonPackages; [
+    mock
+  ];
+
+  propagatedBuildInputs = with pythonPackages; [
+    requests ruamel_yaml appdirs
+    sleekxmpp dns
+    emoji
+    psutil
+    matrix-client
+    dbus-python
+  ];
+
+  checkPhase = ''
+    HOME=$(mktemp -d) ${pythonPackages.python.interpreter} setup.py test
+  '';
+
+  meta = with stdenv.lib; {
+    description = "A utility for sending notifications, on demand and when commands finish";
+    homepage = http://ntfy.rtfd.org/;
+    license = licenses.gpl3;
+    maintainers = with maintainers; [ jfrankenau kamilchm ];
+  };
+}