about summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorLily Ballard <lily@sb.org>2020-05-26 16:33:32 -0700
committerLily Ballard <lily@sb.org>2020-05-26 16:42:21 -0700
commite3f1712b7a9c00ff84ba06e7e04fc27491384bef (patch)
treeeaf706422bc8b53441c3e95ffb9d84252ab13166 /pkgs/tools
parentac3128f22dc42b54b38976a87f5c3fe22046bd25 (diff)
downloadnixlib-e3f1712b7a9c00ff84ba06e7e04fc27491384bef.tar
nixlib-e3f1712b7a9c00ff84ba06e7e04fc27491384bef.tar.gz
nixlib-e3f1712b7a9c00ff84ba06e7e04fc27491384bef.tar.bz2
nixlib-e3f1712b7a9c00ff84ba06e7e04fc27491384bef.tar.lz
nixlib-e3f1712b7a9c00ff84ba06e7e04fc27491384bef.tar.xz
nixlib-e3f1712b7a9c00ff84ba06e7e04fc27491384bef.tar.zst
nixlib-e3f1712b7a9c00ff84ba06e7e04fc27491384bef.zip
bat: 0.15.1 -> 0.15.3
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/misc/bat/default.nix17
-rw-r--r--pkgs/tools/misc/bat/macos.patch13
2 files changed, 5 insertions, 25 deletions
diff --git a/pkgs/tools/misc/bat/default.nix b/pkgs/tools/misc/bat/default.nix
index 95bc44dcce06..9c7501719912 100644
--- a/pkgs/tools/misc/bat/default.nix
+++ b/pkgs/tools/misc/bat/default.nix
@@ -1,32 +1,25 @@
-{ stdenv, rustPlatform, fetchFromGitHub, llvmPackages, pkgconfig, less
+{ stdenv, rustPlatform, fetchFromGitHub, pkgconfig, less
 , Security, libiconv, installShellFiles, makeWrapper
 }:
 
 rustPlatform.buildRustPackage rec {
   pname   = "bat";
-  version = "0.15.1";
+  version = "0.15.3";
 
   src = fetchFromGitHub {
     owner  = "sharkdp";
     repo   = pname;
     rev    = "v${version}";
-    sha256 = "10cs94ja1dmn0f24gqkcy8rf68b3b43k6qpbb5njbg0hcx3x6cyj";
+    sha256 = "0893xjnrjmhhzccfb57w5s7wlf6z4cwxvrxj8qb5jnmrgkfaw86b";
     fetchSubmodules = true;
   };
 
-  cargoSha256 = "13cphi08bp6lg054acgliir8dx2jajll4m3c4xxy04skmx555zr8";
+  cargoSha256 = "0mcff6nsd9g39xdhsf06zxs7pmq27nqfxdk0lwh83lqmnzdp01sf";
 
-  # Disable test that's broken on macOS.
-  # This should probably be removed on the next release.
-  # https://github.com/sharkdp/bat/issues/983
-  patches = [ ./macos.patch ];
-
-  nativeBuildInputs = [ pkgconfig llvmPackages.libclang installShellFiles makeWrapper ];
+  nativeBuildInputs = [ pkgconfig installShellFiles makeWrapper ];
 
   buildInputs = stdenv.lib.optionals stdenv.isDarwin [ Security libiconv ];
 
-  LIBCLANG_PATH = "${llvmPackages.libclang}/lib";
-
   postInstall = ''
     installManPage $releaseDir/build/bat-*/out/assets/manual/bat.1
     installShellCompletion $releaseDir/build/bat-*/out/assets/completions/bat.fish
diff --git a/pkgs/tools/misc/bat/macos.patch b/pkgs/tools/misc/bat/macos.patch
deleted file mode 100644
index 549782f0c91b..000000000000
--- a/pkgs/tools/misc/bat/macos.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/src/assets.rs b/src/assets.rs
-index 4f8556f..222abc2 100644
---- a/src/assets.rs
-+++ b/src/assets.rs
-@@ -336,7 +336,7 @@ mod tests {
-         assert_eq!(test.syntax_for_file("Makefile"), "Makefile");
-     }
- 
--    #[cfg(unix)]
-+    #[cfg(all(unix,not(target_os = "macos")))]
-     #[test]
-     fn syntax_detection_invalid_utf8() {
-         use std::os::unix::ffi::OsStrExt;