about summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2008-05-27 07:49:55 +0000
committerEelco Dolstra <eelco.dolstra@logicblox.com>2008-05-27 07:49:55 +0000
commite21b6b6ee58077b235b998f85c6c9122c52dd465 (patch)
tree017bab49bb3fc85e1583564984cd064bbb209eae /pkgs/tools
parent2ead4b20b52445ec3560c3d530e820ce5a05204a (diff)
downloadnixlib-e21b6b6ee58077b235b998f85c6c9122c52dd465.tar
nixlib-e21b6b6ee58077b235b998f85c6c9122c52dd465.tar.gz
nixlib-e21b6b6ee58077b235b998f85c6c9122c52dd465.tar.bz2
nixlib-e21b6b6ee58077b235b998f85c6c9122c52dd465.tar.lz
nixlib-e21b6b6ee58077b235b998f85c6c9122c52dd465.tar.xz
nixlib-e21b6b6ee58077b235b998f85c6c9122c52dd465.tar.zst
nixlib-e21b6b6ee58077b235b998f85c6c9122c52dd465.zip
* curl: build with OpenSSL (https) support by default.
* Some fetchurl-related refactoring.  The `realCurl' attribute is
  gone, `curl' is the real thing.  To prevent an infinite recursion in
  `fetchurl' (because it depends on curl and building curl needs
  fetchurl), curl and its dependencies (openssl, zlib, perl) use
  `fetchurlBoot', which is the fetchurl used by the previous bootstrap
  phase (e.g. the statically linked version of curl for
  stdenv-linux).  So as a result you can use https:// urls almost
  everywhere.

  There's also some hackery to prevent a different curl from being
  built in every stdenv-linux bootstrap phase (namely the
  stdenv.fetchurl attribute which allows fetchurl to be overriden
  everywhere).

svn path=/nixpkgs/trunk/; revision=11905
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/networking/curl/default.nix9
1 files changed, 8 insertions, 1 deletions
diff --git a/pkgs/tools/networking/curl/default.nix b/pkgs/tools/networking/curl/default.nix
index 7f3488b2f355..85a9ab957d6c 100644
--- a/pkgs/tools/networking/curl/default.nix
+++ b/pkgs/tools/networking/curl/default.nix
@@ -18,7 +18,14 @@ stdenv.mkDerivation {
   CFLAGS = if stdenv ? isDietLibC then "-DHAVE_INET_NTOA_R_2_ARGS=1" else "";
   CXX = "g++";
   CXXCPP = "g++ -E";
-  inherit sslSupport openssl;
+
+  passthru = {
+    inherit sslSupport openssl;
+  };
+
+  preConfigure = ''
+    substituteInPlace configure --replace /usr/bin /no-such-path
+  '';
 
   patches = [
     /* Fixes broken retry support when a timeout is used.  The