about summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorJörg Thalheim <Mic92@users.noreply.github.com>2017-06-05 22:23:01 +0100
committerGitHub <noreply@github.com>2017-06-05 22:23:01 +0100
commitdffec16abd218ed1e1381e659ceac7c606c13262 (patch)
tree58cf46366ec141d97fc3321c7ebcc41f5da76504 /pkgs/tools
parente99e43cc4ca9870d901cfe37d4d75ff2efdf937f (diff)
parentb81124b4fb9084aa1f6cc6f7b134a27200c7c0ed (diff)
downloadnixlib-dffec16abd218ed1e1381e659ceac7c606c13262.tar
nixlib-dffec16abd218ed1e1381e659ceac7c606c13262.tar.gz
nixlib-dffec16abd218ed1e1381e659ceac7c606c13262.tar.bz2
nixlib-dffec16abd218ed1e1381e659ceac7c606c13262.tar.lz
nixlib-dffec16abd218ed1e1381e659ceac7c606c13262.tar.xz
nixlib-dffec16abd218ed1e1381e659ceac7c606c13262.tar.zst
nixlib-dffec16abd218ed1e1381e659ceac7c606c13262.zip
Merge pull request #26410 from kierdavis/hooks
Fix hooks not being called when overriding phases in various packages
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/misc/ckb/default.nix4
-rw-r--r--pkgs/tools/security/hashcat/hashcat3/default.nix2
2 files changed, 6 insertions, 0 deletions
diff --git a/pkgs/tools/misc/ckb/default.nix b/pkgs/tools/misc/ckb/default.nix
index f2dc5150bbd7..b90adfd5852c 100644
--- a/pkgs/tools/misc/ckb/default.nix
+++ b/pkgs/tools/misc/ckb/default.nix
@@ -29,8 +29,12 @@ stdenv.mkDerivation rec {
   doCheck = false;
 
   installPhase = ''
+    runHook preInstall
+
     install -D --mode 0755 --target-directory $out/bin bin/ckb-daemon bin/ckb
     install -D --mode 0755 --target-directory $out/libexec/ckb-animations bin/ckb-animations/*
+
+    runHook postInstall
   '';
 
   meta = with stdenv.lib; {
diff --git a/pkgs/tools/security/hashcat/hashcat3/default.nix b/pkgs/tools/security/hashcat/hashcat3/default.nix
index 810d9df9e2fe..c8a8acf907d3 100644
--- a/pkgs/tools/security/hashcat/hashcat3/default.nix
+++ b/pkgs/tools/security/hashcat/hashcat3/default.nix
@@ -18,7 +18,9 @@ stdenv.mkDerivation rec {
 
   # $out is not known until the build has started.
   configurePhase = ''
+    runHook preConfigure
     makeFlags="$makeFlags PREFIX=$out"
+    runHook postConfigure
   '';
 
   postFixup = ''