about summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorJan Tojnar <jtojnar@gmail.com>2020-04-04 11:05:00 +0200
committerJan Tojnar <jtojnar@gmail.com>2020-04-04 11:05:00 +0200
commitdf28c41854b00b043ae551523d8a78aa7ed90feb (patch)
treec97326e1a31bf9e31a5f940b0b9756fed006d7bb /pkgs/tools
parent8edcff87f24c8f2cfc30931cc6e73e6d22a0bde0 (diff)
downloadnixlib-df28c41854b00b043ae551523d8a78aa7ed90feb.tar
nixlib-df28c41854b00b043ae551523d8a78aa7ed90feb.tar.gz
nixlib-df28c41854b00b043ae551523d8a78aa7ed90feb.tar.bz2
nixlib-df28c41854b00b043ae551523d8a78aa7ed90feb.tar.lz
nixlib-df28c41854b00b043ae551523d8a78aa7ed90feb.tar.xz
nixlib-df28c41854b00b043ae551523d8a78aa7ed90feb.tar.zst
nixlib-df28c41854b00b043ae551523d8a78aa7ed90feb.zip
neopg: fix build
It was using libusb-compat instead of libusb1, and the former no longer propagates the latter.

Also move cmake and gettext to nativeBuildInputs.
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/security/neopg/default.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/pkgs/tools/security/neopg/default.nix b/pkgs/tools/security/neopg/default.nix
index c58772346eea..73451b124350 100644
--- a/pkgs/tools/security/neopg/default.nix
+++ b/pkgs/tools/security/neopg/default.nix
@@ -7,7 +7,7 @@
 , curl
 , gettext
 , pkgconfig
-, libusb
+, libusb1
 , gnutls }:
 
 stdenv.mkDerivation rec {
@@ -22,9 +22,9 @@ stdenv.mkDerivation rec {
     fetchSubmodules = true;
   };
 
-  nativeBuildInputs = [ pkgconfig ];
+  nativeBuildInputs = [  cmake gettext pkgconfig ];
 
-  buildInputs = [ cmake sqlite botan2 boost curl gettext libusb gnutls ];
+  buildInputs = [ sqlite botan2 boost curl libusb1 gnutls ];
 
   doCheck = true;
   checkTarget = "test";