about summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorShea Levy <shea@shealevy.com>2014-01-19 12:23:37 -0500
committerShea Levy <shea@shealevy.com>2014-01-19 12:23:37 -0500
commitd7bf8677a3e23a318d1649be16aa6d518980d2ed (patch)
treeea755e2c88901c878bda0b6a63b98720093693e8 /pkgs/tools
parent03c9791e0a7b65813de51c6450f126ddd62514cb (diff)
parent9f9244f06109f1d5cc706e47334cd14f44a78ea8 (diff)
downloadnixlib-d7bf8677a3e23a318d1649be16aa6d518980d2ed.tar
nixlib-d7bf8677a3e23a318d1649be16aa6d518980d2ed.tar.gz
nixlib-d7bf8677a3e23a318d1649be16aa6d518980d2ed.tar.bz2
nixlib-d7bf8677a3e23a318d1649be16aa6d518980d2ed.tar.lz
nixlib-d7bf8677a3e23a318d1649be16aa6d518980d2ed.tar.xz
nixlib-d7bf8677a3e23a318d1649be16aa6d518980d2ed.tar.zst
nixlib-d7bf8677a3e23a318d1649be16aa6d518980d2ed.zip
Merge branch 'ag' of git://github.com/madjar/nixpkgs
silver-search: Add

Signed-off-by: Shea Levy <shea@shealevy.com>
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/text/silver-searcher/default.nix22
1 files changed, 22 insertions, 0 deletions
diff --git a/pkgs/tools/text/silver-searcher/default.nix b/pkgs/tools/text/silver-searcher/default.nix
new file mode 100644
index 000000000000..83a89cfb6028
--- /dev/null
+++ b/pkgs/tools/text/silver-searcher/default.nix
@@ -0,0 +1,22 @@
+{stdenv, fetchgit, autoreconfHook, pkgconfig, pcre, zlib, lzma}:
+
+let release = "0.18.1"; in
+stdenv.mkDerivation {
+  name = "silver-searcher-${release}";
+
+  src = fetchgit {
+    url = "https://github.com/ggreer/the_silver_searcher.git";
+    rev = "refs/tags/${release}";
+    sha256 = "bf2c8f3c68895e0ee00d373c1d87201e806b413bb28373ee168e375f2a095ec5";
+  };
+
+  buildInputs = [ autoreconfHook pkgconfig pcre zlib lzma ];
+
+  meta = {
+    homepage = https://github.com/ggreer/the_silver_searcher/;
+    description = "A code-searching tool similar to ack, but faster";
+    maintainers = [ stdenv.lib.maintainers.madjar ];
+    platforms = stdenv.lib.platforms.all;
+    license = stdenv.lib.licenses.asl20;
+  };
+}