about summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorJonas Chevalier <zimbatm@zimbatm.com>2023-11-21 13:58:34 +0100
committerGitHub <noreply@github.com>2023-11-21 13:58:34 +0100
commitd6671b3d35007c69ce452890deca00d94a05ed76 (patch)
treea3b1b8d4ed7eb916c06276ac7b1403872b55b204 /pkgs/tools
parent506a458ce18fcb161c10c8fd5b90a6e4cf2517fc (diff)
parentb16e02b405d635bbb15629b874a57549f2eeeb94 (diff)
downloadnixlib-d6671b3d35007c69ce452890deca00d94a05ed76.tar
nixlib-d6671b3d35007c69ce452890deca00d94a05ed76.tar.gz
nixlib-d6671b3d35007c69ce452890deca00d94a05ed76.tar.bz2
nixlib-d6671b3d35007c69ce452890deca00d94a05ed76.tar.lz
nixlib-d6671b3d35007c69ce452890deca00d94a05ed76.tar.xz
nixlib-d6671b3d35007c69ce452890deca00d94a05ed76.tar.zst
nixlib-d6671b3d35007c69ce452890deca00d94a05ed76.zip
Merge pull request #268866 from brianmcgillion/mdbook-footnote
mdbook-footnote: init 0.1.1
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/text/mdbook-footnote/default.nix28
1 files changed, 28 insertions, 0 deletions
diff --git a/pkgs/tools/text/mdbook-footnote/default.nix b/pkgs/tools/text/mdbook-footnote/default.nix
new file mode 100644
index 000000000000..d69c7e4fdd86
--- /dev/null
+++ b/pkgs/tools/text/mdbook-footnote/default.nix
@@ -0,0 +1,28 @@
+{ lib
+, stdenv
+, fetchFromGitHub
+, rustPlatform
+, CoreServices
+}:
+rustPlatform.buildRustPackage rec {
+  pname = "mdbook-footnote";
+  version = "0.1.1";
+
+  src = fetchFromGitHub {
+    owner = "daviddrysdale";
+    repo = "mdbook-footnote";
+    rev = "v${version}";
+    hash = "sha256-WUMgm1hwsU9BeheLfb8Di0AfvVQ6j92kXxH2SyG3ses=";
+  };
+
+  cargoSha256 = "sha256-Ig+uVCO5oHIkkvFsKiBiUFzjUgH/Pydn4MVJHb2wKGc=";
+
+  buildInputs = lib.optionals stdenv.isDarwin [ CoreServices ];
+
+  meta = with lib; {
+    description = "A preprocessor for mdbook to support the inclusion of automatically numbered footnotes";
+    homepage = "https://github.com/daviddrysdale/mdbook-footnote";
+    license = licenses.asl20;
+    maintainers = with maintainers; [ brianmcgillion ];
+  };
+}