about summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorRuud van Asseldonk <dev@veniogames.com>2020-05-19 23:01:00 +0200
committerRuud van Asseldonk <dev@veniogames.com>2020-05-19 23:11:43 +0200
commitd4c80a478b9b8d3303f39fb788f382dfaa823bdc (patch)
tree7e5938372044fc7d66398f8262b5d9698b738816 /pkgs/tools
parentaeeb341c3e127db39699005e5928ad7ba30547d3 (diff)
downloadnixlib-d4c80a478b9b8d3303f39fb788f382dfaa823bdc.tar
nixlib-d4c80a478b9b8d3303f39fb788f382dfaa823bdc.tar.gz
nixlib-d4c80a478b9b8d3303f39fb788f382dfaa823bdc.tar.bz2
nixlib-d4c80a478b9b8d3303f39fb788f382dfaa823bdc.tar.lz
nixlib-d4c80a478b9b8d3303f39fb788f382dfaa823bdc.tar.xz
nixlib-d4c80a478b9b8d3303f39fb788f382dfaa823bdc.tar.zst
nixlib-d4c80a478b9b8d3303f39fb788f382dfaa823bdc.zip
acme-client: 0.2.5 -> 1.0.0
The upstream version fails to compile due to a missing limits.h include.
I added a patch to fix that.

I opened a pull request to upstream it too, but the project has moved
from GitHub onto sr.ht and now asks me to send a patch to the mailing
list. My default email client is not really suitable for that, and
getting git-send-email set up will take some work, so in the meantime
it is easier to just patch it here.
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/networking/acme-client/default.nix6
-rw-r--r--pkgs/tools/networking/acme-client/limits.h.patch41
2 files changed, 45 insertions, 2 deletions
diff --git a/pkgs/tools/networking/acme-client/default.nix b/pkgs/tools/networking/acme-client/default.nix
index 06c2898248d0..e05adae530eb 100644
--- a/pkgs/tools/networking/acme-client/default.nix
+++ b/pkgs/tools/networking/acme-client/default.nix
@@ -12,13 +12,13 @@ with stdenv.lib;
 
 stdenv.mkDerivation rec {
   pname = "acme-client";
-  version = "0.2.5";
+  version = "1.0.0";
 
   src = fetchFromGitHub {
     owner = "graywolf";
     repo = "acme-client-portable";
     rev = "v${version}";
-    sha256 = "1d9yk87nj5gizkq26m4wqfh4xhlrn5xlfj7mfgvrpsdiwibqxrrw";
+    sha256 = "1p6jbxg00ing9v3jnpvq234w5r2gf8b04k9qm06mn336lcd2lgpl";
   };
 
   nativeBuildInputs = [ autoreconfHook bison pkgconfig ];
@@ -26,6 +26,8 @@ stdenv.mkDerivation rec {
 
   makeFlags = [ "PREFIX=${placeholder "out"}" ];
 
+  patches = [ ./limits.h.patch ];
+
   meta = {
     homepage = "https://github.com/graywolf/acme-client-portable";
     description = "Secure ACME/Let's Encrypt client";
diff --git a/pkgs/tools/networking/acme-client/limits.h.patch b/pkgs/tools/networking/acme-client/limits.h.patch
new file mode 100644
index 000000000000..2a2e04fb8fac
--- /dev/null
+++ b/pkgs/tools/networking/acme-client/limits.h.patch
@@ -0,0 +1,41 @@
+From 05b32236adf0f3f43d74b7824b7b20bc917c6db9 Mon Sep 17 00:00:00 2001
+From: Ruud van Asseldonk <dev@veniogames.com>
+Date: Tue, 19 May 2020 22:32:01 +0200
+Subject: [PATCH] Include limits.h in compat.c
+
+Without this, the compiler says:
+
+    compat.c: In function 'strtonum':
+    compat.c:235:19: error: 'LLONG_MIN' undeclared (first use in this function)
+      235 |   else if ((ll == LLONG_MIN && errno == ERANGE) || ll < minval)
+          |                   ^~~~~~~~~
+    compat.c:9:1: note: 'LLONG_MIN' is defined in header '<limits.h>'; did you forget to '#include <limits.h>'?
+        8 | #include <unistd.h>
+      +++ |+#include <limits.h>
+        9 |
+    compat.c:235:19: note: each undeclared identifier is reported only once for each function it appears in
+      235 |   else if ((ll == LLONG_MIN && errno == ERANGE) || ll < minval)
+          |                   ^~~~~~~~~
+    compat.c:237:19: error: 'LLONG_MAX' undeclared (first use in this function)
+      237 |   else if ((ll == LLONG_MAX && errno == ERANGE) || ll > maxval)
+          |                   ^~~~~~~~~
+    compat.c:237:19: note: 'LLONG_MAX' is defined in header '<limits.h>'; did you forget to '#include <limits.h>'?
+---
+ compat.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git ./compat.c ./compat.c
+index 72a2f96..f990eca 100644
+--- compat.c
++++ compat.c
+@@ -1,6 +1,7 @@
+ #include "compat.h"
+ 
+ #include <errno.h>
++#include <limits.h>
+ #include <stdint.h>
+ #include <stdio.h>
+ #include <stdlib.h>
+-- 
+2.26.2
+