about summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorJörg Thalheim <Mic92@users.noreply.github.com>2019-08-03 09:14:08 +0100
committerGitHub <noreply@github.com>2019-08-03 09:14:08 +0100
commitd02ead41f87a0709879a522a809223b2665b06ff (patch)
tree77f4909407f4df86c848283bfb02d1c705fa5038 /pkgs/tools
parentdc5584adeabc4ca369ec98107778e4ab4758152f (diff)
parentbdd7b5a3abbc6f826f608dd68f5c0ed18fcff9cb (diff)
downloadnixlib-d02ead41f87a0709879a522a809223b2665b06ff.tar
nixlib-d02ead41f87a0709879a522a809223b2665b06ff.tar.gz
nixlib-d02ead41f87a0709879a522a809223b2665b06ff.tar.bz2
nixlib-d02ead41f87a0709879a522a809223b2665b06ff.tar.lz
nixlib-d02ead41f87a0709879a522a809223b2665b06ff.tar.xz
nixlib-d02ead41f87a0709879a522a809223b2665b06ff.tar.zst
nixlib-d02ead41f87a0709879a522a809223b2665b06ff.zip
Merge pull request #65407 from alunduil/add-zfs-replication
Add zfs replication
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/backup/zfs-replicate/default.nix42
1 files changed, 42 insertions, 0 deletions
diff --git a/pkgs/tools/backup/zfs-replicate/default.nix b/pkgs/tools/backup/zfs-replicate/default.nix
new file mode 100644
index 000000000000..83fa76b0800e
--- /dev/null
+++ b/pkgs/tools/backup/zfs-replicate/default.nix
@@ -0,0 +1,42 @@
+{ buildPythonApplication, click, fetchPypi, hypothesis, mypy, pytest
+, pytestcov, pytestrunner, stdenv, stringcase
+}:
+
+buildPythonApplication rec {
+  pname = "zfs-replicate";
+  version = "1.1.11";
+
+  src = fetchPypi {
+    inherit pname version;
+    sha256 = "0386xc6rw6bhzw2a08g90afb3snqhm1ikx65bjfh22ha69fwmga8";
+  };
+
+  checkInputs = [
+    hypothesis
+    mypy
+    pytest
+    pytestcov
+  ];
+
+  buildInputs = [
+    pytestrunner
+  ];
+
+  propagatedBuildInputs = [
+    click
+    stringcase
+  ];
+
+  doCheck = true;
+
+  checkPhase = ''
+    pytest --doctest-modules
+  '';
+
+  meta = with stdenv.lib; {
+    homepage = https://github.com/alunduil/zfs-replicate;
+    description = "ZFS Snapshot Replication";
+    license = licenses.bsd2;
+    maintainers = with maintainers; [ alunduil ];
+  };
+}