about summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorNikolay Amiantov <ab@fmap.me>2016-03-11 01:58:22 +0300
committerNikolay Amiantov <ab@fmap.me>2016-03-11 01:58:40 +0300
commitcf9ddb27d6aa53826f7191cbddb561a05554018c (patch)
tree03bb36a57aceda893d7ee2b53743bbca7137db96 /pkgs/tools
parent4e58b33deea7d62f109bdb63d5d79397044b5d90 (diff)
downloadnixlib-cf9ddb27d6aa53826f7191cbddb561a05554018c.tar
nixlib-cf9ddb27d6aa53826f7191cbddb561a05554018c.tar.gz
nixlib-cf9ddb27d6aa53826f7191cbddb561a05554018c.tar.bz2
nixlib-cf9ddb27d6aa53826f7191cbddb561a05554018c.tar.lz
nixlib-cf9ddb27d6aa53826f7191cbddb561a05554018c.tar.xz
nixlib-cf9ddb27d6aa53826f7191cbddb561a05554018c.tar.zst
nixlib-cf9ddb27d6aa53826f7191cbddb561a05554018c.zip
colord: fix udev rules, add sane support
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/misc/colord/default.nix7
1 files changed, 4 insertions, 3 deletions
diff --git a/pkgs/tools/misc/colord/default.nix b/pkgs/tools/misc/colord/default.nix
index 3ba5a138e5a7..7e6c3f30784e 100644
--- a/pkgs/tools/misc/colord/default.nix
+++ b/pkgs/tools/misc/colord/default.nix
@@ -1,7 +1,7 @@
 { stdenv, fetchzip, fetchgit, bashCompletion
 , glib, polkit, pkgconfig, intltool, gusb, libusb1, lcms2, sqlite, systemd, dbus
 , automake, autoconf, libtool, gtk_doc, which, gobjectIntrospection, argyllcms
-, libgudev }:
+, libgudev, sane-backends }:
 
 stdenv.mkDerivation rec {
   name = "colord-1.2.12";
@@ -14,7 +14,8 @@ stdenv.mkDerivation rec {
   enableParallelBuilding = true;
 
   configureFlags = [
-    "--with-udevrulesdir=$out/lib/udev/rules.d"
+    "--enable-sane"
+    "--with-udevrulesdir=$(out)/lib/udev/rules.d"
     "--with-systemdsystemunitdir=$(out)/etc/systemd/system"
     "--localstatedir=/var"
     "--disable-bash-completion"
@@ -27,7 +28,7 @@ stdenv.mkDerivation rec {
   '';
 
   buildInputs = [ glib polkit pkgconfig intltool gusb libusb1 lcms2 sqlite systemd dbus gobjectIntrospection
-                  bashCompletion argyllcms automake autoconf libgudev ];
+                  bashCompletion argyllcms automake autoconf libgudev sane-backends ];
 
   postInstall = ''
     mkdir -p $out/etc/bash_completion.d