about summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorJan Tojnar <jtojnar@gmail.com>2018-11-11 04:01:24 +0100
committerGitHub <noreply@github.com>2018-11-11 04:01:24 +0100
commitcf7e7127c56ab04efaf1459d09810735bae52ccd (patch)
tree6b8d9d47f7a249804d3b307e73f9e120fd7d9bb6 /pkgs/tools
parent316ad962564899e7cd80edb780a5d43ec7b76a1b (diff)
parent5d53675c2fa583c23bc955d0bf6c25bcc47af78f (diff)
downloadnixlib-cf7e7127c56ab04efaf1459d09810735bae52ccd.tar
nixlib-cf7e7127c56ab04efaf1459d09810735bae52ccd.tar.gz
nixlib-cf7e7127c56ab04efaf1459d09810735bae52ccd.tar.bz2
nixlib-cf7e7127c56ab04efaf1459d09810735bae52ccd.tar.lz
nixlib-cf7e7127c56ab04efaf1459d09810735bae52ccd.tar.xz
nixlib-cf7e7127c56ab04efaf1459d09810735bae52ccd.tar.zst
nixlib-cf7e7127c56ab04efaf1459d09810735bae52ccd.zip
Merge pull request #48270 from Melkor333/wpgtk
wpgtk: init at 5.7.4
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/X11/wpgtk/default.nix49
1 files changed, 49 insertions, 0 deletions
diff --git a/pkgs/tools/X11/wpgtk/default.nix b/pkgs/tools/X11/wpgtk/default.nix
new file mode 100644
index 000000000000..b6ba431da9d6
--- /dev/null
+++ b/pkgs/tools/X11/wpgtk/default.nix
@@ -0,0 +1,49 @@
+{ stdenv, python36Packages, fetchFromGitHub, pywal, feh, libxslt, imagemagick,
+  gobjectIntrospection, gtk3, wrapGAppsHook, gnome3 }:
+
+python36Packages.buildPythonApplication rec {
+  pname = "wpgtk";
+  version = "5.7.4";
+
+  src = fetchFromGitHub {
+    owner = "deviantfero";
+    repo = "wpgtk";
+    rev = "${version}";
+    sha256 = "0c0kmc18lbr7nk3hh44hai9z06lfsgwxnjdv02hpjwrxg40zh726";
+  };
+
+  pythonPath = [
+    python36Packages.pygobject3
+    python36Packages.pillow
+    pywal
+    imagemagick
+  ];
+
+  buildInputs = [
+    wrapGAppsHook
+    gtk3
+    gobjectIntrospection
+    gnome3.adwaita-icon-theme
+    libxslt
+  ];
+
+  # The $HOME variable must be set to build the package. A "permission denied" error will occur otherwise
+  preBuild = ''
+      export HOME=$(pwd)
+  '';
+
+  meta = with stdenv.lib; {
+    description = "Template based wallpaper/colorscheme generator and manager";
+    longDescription = ''
+     In short, wpgtk is a colorscheme/wallpaper manager with a template system attached which lets you create templates from any textfile and will replace keywords on it on the fly, allowing for great styling and theming possibilities.
+
+     wpgtk uses pywal as its colorscheme generator, but builds upon it with a UI and other features, such as the abilty to mix and edit the colorschemes generated and save them with their respective wallpapers, having light and dark themes, hackable and fast GTK+ theme made specifically for wpgtk and custom keywords and values to replace in templates.
+
+     INFO: To work properly, this tool needs "programs.dconf.enable = true" on nixos or dconf installed. A reboot may be required after installing dconf.
+     '';
+    homepage = https://github.com/deviantfero/wpgtk;
+    license = licenses.gpl2;
+    platforms = platforms.linux;
+    maintainers = [ maintainers.melkor333 ];
+  };
+}