about summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorArseniy Seroka <jagajaga@users.noreply.github.com>2016-03-31 16:48:50 +0300
committerArseniy Seroka <jagajaga@users.noreply.github.com>2016-03-31 16:48:50 +0300
commitca30594c87f33257ef108b600cff34ca488903f9 (patch)
tree077fc4f906f913e1baa53bc991f84a12bfb68bd0 /pkgs/tools
parent4e356cefd7cc2b4f581db53203222ee495f7285f (diff)
parent1d09c97ac40dc3c1b780055409d57281c49f234a (diff)
downloadnixlib-ca30594c87f33257ef108b600cff34ca488903f9.tar
nixlib-ca30594c87f33257ef108b600cff34ca488903f9.tar.gz
nixlib-ca30594c87f33257ef108b600cff34ca488903f9.tar.bz2
nixlib-ca30594c87f33257ef108b600cff34ca488903f9.tar.lz
nixlib-ca30594c87f33257ef108b600cff34ca488903f9.tar.xz
nixlib-ca30594c87f33257ef108b600cff34ca488903f9.tar.zst
nixlib-ca30594c87f33257ef108b600cff34ca488903f9.zip
Merge pull request #14095 from guaraqe/grive-2
grive2: init at 0.5.0
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/filesystems/grive2/default.nix25
1 files changed, 25 insertions, 0 deletions
diff --git a/pkgs/tools/filesystems/grive2/default.nix b/pkgs/tools/filesystems/grive2/default.nix
new file mode 100644
index 000000000000..a3ee1b67bab2
--- /dev/null
+++ b/pkgs/tools/filesystems/grive2/default.nix
@@ -0,0 +1,25 @@
+{ stdenv, fetchFromGitHub, pkgconfig, fetchurl, yajl, cmake, libgcrypt, curl, expat, boost, binutils }:
+
+stdenv.mkDerivation rec {
+  version = "0.5.0";
+  name = "grive2-${version}";
+
+  src = fetchFromGitHub {
+    owner = "vitalif";
+    repo = "grive2";
+    rev =  "v${version}";
+    sha256 = "0gyic9228j25l5x8qj9xxxp2cgbw6y4skxqx0xrq6qilhv4lj23c";
+  };
+
+  nativeBuildInputs = [ cmake pkgconfig ];
+
+  buildInputs = [ libgcrypt yajl curl expat stdenv boost binutils ];
+
+  meta = with stdenv.lib; {
+    description = "A console Google Drive client";
+    homepage = https://github.com/vitalif/grive2;
+    license = licenses.gpl2;
+    platforms = platforms.linux;
+  };
+
+}